Switch to full style
Data recovery and disk repair questions and discussions related to old-fashioned SATA, SAS, SCSI, IDE, MFM hard drives - any type of storage device that has moving parts
Post a reply


November 9th, 2011, 13:41

Yes this old chestnut again
(please go easy on me)

Recent-ish Maxtor DiamondMax 22 / Seagate 7200.11
firmware MX15
date code 08384

power on hd with pcb connected to motor
LED:000000CC busy error
doesnt respond to ctrl z

power on hd with pcb isolated from motor
accepts ctrl z
get F3 T> prompt
enter 2 (CR)
but just get
and dont get to F3 2>

I did once get to
F3 2>
but didnt respond to Z

Please give me a hint

I have tried 'waiting longer'

Not sure about the 'shorting read channel'


Re: LED:000000CE

November 9th, 2011, 13:49

At F3 T>
wait 1 minute (no LED messages)
get LED:000000CC ie back to CC and unresponsive

Re: LED:000000CE

November 9th, 2011, 18:52

HDD is locked? or bad heads.

Re: LED:000000CE

November 10th, 2011, 4:27

You must wait longer BEFORE you CTRL+Z.

Re: LED:000000CE

November 10th, 2011, 7:46


I've been trying various delays before the first ^Z and then before doing 2

IF do it too soon get 000000CE
if do it too late get 000000CC

I'm trying some other commands after the initial ^Z
(if do frequent ^Z's and it continues to respond)

? gives the following output

Blks 000E24-000E24 (000001), BufAddr 001C4800-001C49FF, DBA 061C4800, BytesPerBlk 200 Online Cmd SDBP DFB
Blks 000E25-000E25 (000001), BufAddr 001C4A00-001C4BFF, DBA 061C4A00, BytesPerBlk 200 Cmd Input Buf
Blks 000E26-000E26 (000001), BufAddr 001C4C00-001C4DFF, DBA 061C4C00, BytesPerBlk 200 Diag Batch File
Blks 000E27-000E27 (000001), BufAddr 001C4E00-001C4FFF, DBA 061C4E00, BytesPerBlk 200
Blks 000E28-000E28 (000001), BufAddr 001C5000-001C51FF, DBA 061C5000, BytesPerBlk 200
Blks 000E29-000E29 (000001), BufAddr 001C5200-001C53FF, DBA 061C5200, BytesPerBlk 200
Blks 000E2A-000E2A (000001), BufAddr 001C5400-001C55FF, DBA 061C5400, BytesPerBlk 200
Blks 000E2B-000E2B (000001), BufAddr 001C5600-001C57FF, DBA 061C5600, BytesPerBlk 200
Blks 000E2C-000E2F (000004), BufAddr 001C5800-001C5FFF, DBA 061C5800, BytesPerBlk 200
Blks 000E30-000E33 (000004), BufAddr 001C6000-001C67FF, DBA 061C6000, BytesPerBlk 200
Blks 000E34-000E37 (000004), BufAddr 001C6800-001C6FFF, DBA 061C6800, BytesPerBlk 200
Blks 000E38-000E3B (000004), BufAddr 001C7000-001C77FF, DBA 061C7000, BytesPerBlk 200
Blks 000E3C-000E5B (000020), BufAddr 001C7800-001CB7FF, DBA 061C7800, BytesPerBlk 200 Diag Mode Cmd SDBP DFB
Blks 000E5C-000E7B (000020), BufAddr 001CB800-001CF7FF, DBA 061CB800, BytesPerBlk 200 Ext Test Service SDBP DSB
Blks 000E7C-000E9B (000020), BufAddr 001CF800-001D37FF, DBA 061CF800, BytesPerBlk 200
Blks 000E9C-000EBB (000020), BufAddr 001D3800-001D77FF, DBA 061D3800, BytesPerBlk 200
Blks 000EBC-000F15 (00005A), BufAddr 001D7800-001E2BFF, DBA 061D7800, BytesPerBlk 200
Blks 000F16-000F6F (00005A), BufAddr 001E2C00-001EDFFF, DBA 061E2C00, BytesPerBlk 200

and keeps responding to further ?'s forever (ie still responsive)

but if do 2 (or 1)
it blocks with 000000CC

I'll see if any other T level commands are working

Re: LED:000000CE

November 10th, 2011, 8:11

Results of other level T commands

^A shows firmware info

. shows
Current R/W User LBA 00000000 LLL CHS 000000.0.0000 PLP CHS 000000.0.0000
R/W Status 1 R/W Error 00000080 Not Ready

^C (firmware reset gives)
Spinning Down

Spin Down Complete (nb motor not connected)
Elapsed Time 0.149 msecs
Delaying 5000 msec

Jumping to Power On Reset
Bogus ISR

(stuck/no response to ^Z)

power cycle, ^Z, back to level T

Re: LED:000000CE

November 10th, 2011, 8:29

At level T
if reconnect motor and do ?
get extra two lines at end
Blks 001769-001AFA (000392), BufAddr 002ED200-0036128F, DBA 062ED200, BytesPerBlk 208 Default Diag Rd Buf
Blks 001B0C-001E9D (000392), BufAddr 00361800-003D588F, DBA 06361800, BytesPerBlk 208 Default Diag Wrt Buf

Re: LED:000000CE

November 10th, 2011, 15:49

^Z with motor disconnected
Have to wait a bit before doing ^A
if too soon -- Error 100A DETSEC 00007001
after 20 seconds or so -- firmware info

ie seems to need the 20 seconds to stabilize
just keep running ^A till it shows as stable

can then /2
Z worked, and rest of procedure worked

Disk recovered ! :D
Post a reply