All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: External Hard drive stopped showing up on windows explorer
PostPosted: September 15th, 2017, 15:21 
Offline

Joined: September 15th, 2017, 15:13
Posts: 3
Location: United States
Hello HDD Gurus,

My external hard drive suddenly stopped showing up on my primary laptop's windows explorer (running windows 10).

The drive is visible on control panel under hardware and also in Device Manager.

Also the device is available in the Disk Management but it is showing as not initialized and the option to initialize seems unavailable for the disk.

The drive is working fine on all other computers.

Any suggestions/help is appreciated.

Thank you


Top
 Profile  
 
 Post subject: Re: External Hard drive stopped showing up on windows explor
PostPosted: September 15th, 2017, 16:13 
Offline
User avatar

Joined: July 12th, 2010, 4:38
Posts: 1075
Location: Portugal
Is it really showing the drive, or maybe the USB adapter?
Do you hear any noises?
Did the HDD fell?

_________________
http://www.facebook.com/PCLAB.Assistencia.Tecnica
ACELab partner


Top
 Profile  
 
 Post subject: Re: External Hard drive stopped showing up on windows explor
PostPosted: September 15th, 2017, 16:41 
Offline

Joined: September 15th, 2017, 15:13
Posts: 3
Location: United States
Yes it is showing up as a drive.
No it isn't making any noise.
I am certain there is no problem with the drive since it works perfectly on other computers.

Thank you


Top
 Profile  
 
 Post subject: Re: External Hard drive stopped showing up on windows explor
PostPosted: September 15th, 2017, 18:00 
Offline

Joined: October 16th, 2013, 13:21
Posts: 717
Location: Brazil
Do you have some antivirus software in this computer that you don´t have in the others ? Maybe it is blocking access to the drive because of some virus or things it may consider a virus ( even if wrongly ) .

Also, you could delete the drive´s entries in device manager, and let windows redetect it, Maybe something about the usb subsystems got corrupted.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 37 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group