All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 27 posts ]  Go to page Previous  1, 2
Author Message
 Post subject: Re: st2000LM005
PostPosted: April 23rd, 2018, 18:30 
Offline

Joined: October 16th, 2013, 13:21
Posts: 717
Location: Brazil
jermy wrote:
if the donor and patient have different preamp the drive will not spin


Then if a donor board with patient rom doesn´t work, even if the rom checks good, that could point to preamp, yes ?

Just a late idea, @mrDRECula, but are you sure the board in the patient is the original one ? Maybe your customer has already tried to swap it ? That could convenientely explain the motor not working.

Also, one other test : put some donor rom in the patient pcb, and test it in the donor hdd. Does it work ?


Top
 Profile  
 
 Post subject: Re: st2000LM005
PostPosted: April 24th, 2018, 5:15 
Offline

Joined: December 21st, 2017, 12:28
Posts: 18
Location: cardiff
thank you all for your help, will update you in few hours


Top
 Profile  
 
 Post subject: Re: st2000LM005
PostPosted: April 24th, 2018, 10:57 
Offline

Joined: December 21st, 2017, 12:28
Posts: 18
Location: cardiff
@fzabkar I am sure the voltage works fine as i tried to read the same model and it reads fine
@jermy the drive doesn't say the fw, so i tried on a model with similar DOM
@rogfanther tried and doesn't spin so the pcb is damaged in first place or the roms aren't compatible

the only thing I haven't tried yet is a usb pcb with donor rom, but it's hard to find at a cheap price.


Top
 Profile  
 
 Post subject: Re: st2000LM005
PostPosted: April 24th, 2018, 15:03 
Offline
User avatar

Joined: September 8th, 2009, 18:21
Posts: 10611
Location: Australia
mrDRECula wrote:
@fzabkar I am sure the voltage works fine as i tried to read the same model and it reads fine

ISTM that you may not understand what I'm saying.

You stated that you were only able to see "&&&&" at the terminal port. I'm suggesting that you measure the voltages at the port to see if they may be too low for your 3.3V (?) TTL adapter.


Attachments:
UART.jpg
UART.jpg [ 14.57 KiB | Viewed 795 times ]

_________________
A backup a day keeps DR away.
Top
 Profile  
 
 Post subject: Re: st2000LM005
PostPosted: April 26th, 2018, 8:46 
Offline

Joined: December 21st, 2017, 12:28
Posts: 18
Location: cardiff
@fzabkar sorry for the delay in the answer, I undestood what you were asking, probably i didn't explain it well. As the pcb was successfully readed with the donor rom I doubt the issue is the terminal. If the problem was the voltage then it shouldn't read the donor in first place.


Top
 Profile  
 
 Post subject: Re: st2000LM005
PostPosted: April 26th, 2018, 13:28 
Offline

Joined: October 16th, 2013, 13:21
Posts: 717
Location: Brazil
in the donor drive, with donor pcb, donor hda and donor rom, can you get meaningful information through terminal ? post it here if possible


Top
 Profile  
 
 Post subject: Re: st2000LM005
PostPosted: April 27th, 2018, 11:50 
Offline

Joined: December 21st, 2017, 12:28
Posts: 18
Location: cardiff
looks like it was the preamp, I found a donor with same rom version and same vendor id and the patient rom and pcb worked on donor hda, while donor pcb and donor rom don't work on patient hda. Thank you all for your time!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 27 posts ]  Go to page Previous  1, 2

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: Google [Bot] and 18 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group