Switch to full style
Data recovery and disk repair questions and discussions related to old-fashioned SATA, SAS, SCSI, IDE, MFM hard drives - any type of storage device that has moving parts
Post a reply

WD 3200AAKS Constantly Power Cycles In Certain Areas

May 5th, 2018, 13:48

I have a WD 3200AAKS that reads fine on all heads from about 18% into the drive and beyond. That first 18% though is a nightmare. The drive will read a sector, cycle the power, and then read the next sector...then the next sector it cycles the power and reads the sector after that. I've tried every DDI setting I can think of. I don't believe it's an issue with the drive physically. I have 3 of my PC3K machines tied up right now so I can't check it yet, but I'm wondering if it's a system area issue with one of the modules. Anyone else seen this? Like I said, it's just that first 18% of the drive that it hits areas where it hangs and cycles the power over and over. Beyond that point, it reads just fine at normal speeds.

Re: WD 3200AAKS Constantly Power Cycles In Certain Areas

May 5th, 2018, 14:04

Pinclite? Just had a case in like this, it came in from a dealer and suspect it had been seriously messed with, there were 'issues' with quite a few A-S critical mods, after lots of time re-building from copy1, 2 and making good, HDD came ready absolutely no issues and cloned >90MB per sec, save for <100 unread UNC sectors, from memory, in my case mods 4Xh, 31h, 03h, 04h seemed to have 'issues'.

Re: WD 3200AAKS Constantly Power Cycles In Certain Areas

May 5th, 2018, 14:25

gtd4242 wrote:I have a WD 3200AAKS that reads fine on all heads from about 18% into the drive and beyond. That first 18% though is a nightmare. The drive will read a sector, cycle the power, and then read the next sector...then the next sector it cycles the power and reads the sector after that. I've tried every DDI setting I can think of. I don't believe it's an issue with the drive physically. I have 3 of my PC3K machines tied up right now so I can't check it yet, but I'm wondering if it's a system area issue with one of the modules. Anyone else seen this? Like I said, it's just that first 18% of the drive that it hits areas where it hangs and cycles the power over and over. Beyond that point, it reads just fine at normal speeds.


Disable background media scan on module 02. Clear RE-LO. This will most likely allow you to image/clone the drive without the mentioned issue.

If the drive still does the same decrese the TIMEOUT value for sector READ. Make it timeout very fast on slow sectors so you can skip them without the drive doing that power cycle sort of thing.

This should allow you to image / clone without the issue. Also disable cache. Don't use read lookhaead at all. This will help.

If all the above fails try PIO mode. It will be a lot slower but if you use it on that bad region only you should be ok.

Re: WD 3200AAKS Constantly Power Cycles In Certain Areas

May 8th, 2018, 15:19

I've done all that was suggested and this drive is just crazy. It works fine and then it hits those areas in that first 18% and no matter what you do, it constantly power cycles almost every sector.

Re: WD 3200AAKS Constantly Power Cycles In Certain Areas

May 8th, 2018, 15:23

Try to clone/image in reverse.

Save all modules, try to regen translator (quick format with P-List).

Re: WD 3200AAKS Constantly Power Cycles In Certain Areas

May 8th, 2018, 15:25

Try to replace the PCB as well just in case ...

Re: WD 3200AAKS Constantly Power Cycles In Certain Areas

May 8th, 2018, 15:27

Spildit wrote:Try to replace the PCB as well just in case ...



I was just about to suggest that, have seen quite a few Tornado drives that wouldn’t read the first ~33% and turned out the PCB was at fault.

Re: WD 3200AAKS Constantly Power Cycles In Certain Areas

May 8th, 2018, 15:32

pcimage wrote:
Spildit wrote:Try to replace the PCB as well just in case ...



I was just about to suggest that, have seen quite a few Tornado drives that wouldn’t read the first ~33% and turned out the PCB was at fault.


AGREEE !!!

FORGET ABOUT MY ADVICE OF TRANSLATOR REGENERATION.

http://www.hddoracle.com/viewtopic.php?f=3&t=255

MOST LIKELY PCB is damaged.

Re: WD 3200AAKS Constantly Power Cycles In Certain Areas

May 8th, 2018, 15:37

Also :

http://www.hddoracle.com/viewtopic.php? ... p=260#p260

http://www.hddoracle.com/viewtopic.php? ... 27&p=15507

So yes ...

for TORNADO ... REPLACE THE PCB !

Re: WD 3200AAKS Constantly Power Cycles In Certain Areas

May 8th, 2018, 15:45

IMO, most likely FW problem than PCB failure.

Re: WD 3200AAKS Constantly Power Cycles In Certain Areas

May 8th, 2018, 15:49

unknown wrote:IMO, most likely FW problem than PCB failure.


Nope ....

Almost for sure PCB.

FW problems would prevent access to ALL LBAs on WD Marvell, for example if translator were damaged or not loaded ....

I've seen problems like the described with translator related issues but ONLY on WDC MCU based - NOT MARVELL like on this case - viewtopic.php?f=1&t=33182

Drive is TORNADO so first thing to try is PCB swap.

Re: WD 3200AAKS Constantly Power Cycles In Certain Areas

May 8th, 2018, 15:54

Drive is PINCLITE.

Re: WD 3200AAKS Constantly Power Cycles In Certain Areas

May 8th, 2018, 16:48

unknown wrote:Drive is PINCLITE.


Well, i would try PCB replacement anyway !

:D :D :D

Re: WD 3200AAKS Constantly Power Cycles In Certain Areas

May 9th, 2018, 9:34

Thanks for all the feedback folks. Going to try and swap PCB's at some point today and will update. Now that I think of it, I had an issue almost like this years ago and it was the PCB.

Re: WD 3200AAKS Constantly Power Cycles In Certain Areas

May 9th, 2018, 14:09

gtd4242 wrote:Thanks for all the feedback folks. Going to try and swap PCB's at some point today and will update. Now that I think of it, I had an issue almost like this years ago and it was the PCB.


Please do let us know !

:D

Re: WD 3200AAKS Constantly Power Cycles In Certain Areas

May 9th, 2018, 14:36

Well, the PCB was the culprit. It's imaging perfectly now. What a crazy job. I just never thought initially, since everything seemed to be good to go past that 18% mark, that there could be an issue with the PCB. It just threw me for a loop at how perfect everything operated past that point. Definitely logging this resolution away.

Re: WD 3200AAKS Constantly Power Cycles In Certain Areas

May 9th, 2018, 15:02

Glad it worked for you. :good:

Re: WD 3200AAKS Constantly Power Cycles In Certain Areas

May 9th, 2018, 15:49

Nice :-)

Re: WD 3200AAKS Constantly Power Cycles In Certain Areas

May 9th, 2018, 16:19

The PCB number that your PINCLITE drive uses is very close to the pcb number that the Tornado drives use and those drives have typical problem exactly like you described so .... It would be reasonable to think that somehow your PCB does have the same similar problems as it's very close and can "share" some of the components (and problems) of the Tornado PCBs that are very well known to fail in that way.

Apart from that i've only seen the described problem on WDC based MCU drives with translator problem as your modules aparently were good so .... Yes it makes 100% sense for the "problem" to be caused by PCB.

:good: :good: :good: :good: :good:

Job well done.

Re: WD 3200AAKS Constantly Power Cycles In Certain Areas

May 9th, 2018, 17:23

Thanks! And thanks for all the input and suggestions.
Post a reply