All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 21 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: Conner CP 2064 head issue
PostPosted: September 3rd, 2018, 15:02 
Offline

Joined: September 3rd, 2018, 14:52
Posts: 10
Location: Almere/The Netherlands
I've got an old Conner CP 2064 harddisk from a Toshiba T1800 laptop that has an issue with moving the heads out of the "landing zone".
At first I thought the heads were stuck to the platters but the drive did spin up normally for a few seconds and then it just powered down and retried the startup cycle.

I opened the harddrive (in a "clean box") and checked if the heads could move freely when the drive is spinning, which they can.
I then connected the drive to a computer and booted it, still nothing.

Next I tried to move the heads from the landing zone ever so slightly (using a small wooden stick to move the electro magnet, not the arm itself) and the drive started initializing.
The PC even booted to MS-DOS 5.0 and all data seems to be ok.
Harddrive keeps working correctly while it is powered on, after powercycling the problem is back though.

What can I do to fix this issue without having to open up the drive and nudge the head assembly every time? Any help is greatly appreciated.


Top
 Profile  
 
 Post subject: Re: Conner CP 2064 head issue
PostPosted: September 3rd, 2018, 15:31 
Offline
User avatar

Joined: September 8th, 2009, 18:21
Posts: 11029
Location: Australia
What does the drive report via its diagnostic (terminal) port?

viewtopic.php?f=1&t=7224

_________________
A backup a day keeps DR away.


Top
 Profile  
 
 Post subject: Re: Conner CP 2064 head issue
PostPosted: September 3rd, 2018, 16:37 
Offline
User avatar

Joined: September 8th, 2009, 18:21
Posts: 11029
Location: Australia
Is the actuator being hindered by a stuck latch?

_________________
A backup a day keeps DR away.


Top
 Profile  
 
 Post subject: Re: Conner CP 2064 head issue
PostPosted: September 3rd, 2018, 17:36 
Offline

Joined: September 3rd, 2018, 14:52
Posts: 10
Location: Almere/The Netherlands
I've read the thread you posted but cannot figure out how to physically connect to the debug port (it's a 2.5" drive btw)

As for the "latch": if you mean some locking mechanism to keep the heads in place while off, no. This drive doesn't have one.


Top
 Profile  
 
 Post subject: Re: Conner CP 2064 head issue
PostPosted: September 3rd, 2018, 17:48 
Offline
User avatar

Joined: September 8th, 2009, 18:21
Posts: 11029
Location: Australia
https://stason.org/TULARC/pc/hard-drives-hdd/conner/CP-2064-64MB-2-5-SSL-IDE-AT.html

CONNER CP2034/CP2064 PRODUCT MANUAL 00501-006

Quote:
At power down or the start of STANDBY MODE or SLEEP MODE the heads are automatically retracted to the inner diameter of the disk and are latched and parked on a landing zone that is off the data tracks.

Quote:
- Automatic actuator latch over data free landing zone during standby mode or power-down

FWIW, there appears to be a glass fuse (?) on the PCB near the HDA connector.

As for the terminal port, you could experiment with the 4 jumper pins at the edge of the PCB. One will be Rx, another will be Tx. Start by looking for data transmissions from each pin.

_________________
A backup a day keeps DR away.


Top
 Profile  
 
 Post subject: Re: Conner CP 2064 head issue
PostPosted: September 3rd, 2018, 17:59 
Offline

Joined: September 3rd, 2018, 14:52
Posts: 10
Location: Almere/The Netherlands
The only latching kind of mechanism I can see must be some sort of magnet, there is nothing mechanically moving that is locking the heads in place.

As for the glass fuse-like component near the connector, if I am correct that should be a diode, judging by the red coloring. I can only see 1 SMD fuse on the board, near the spindle motor and crystal oscillator.

Edit: tried to connect to the rx/tx pins and eventually got some garbage data. It should be 9600 baud like the seagate drives, right?


Top
 Profile  
 
 Post subject: Re: Conner CP 2064 head issue
PostPosted: September 3rd, 2018, 18:12 
Offline
User avatar

Joined: September 8th, 2009, 18:21
Posts: 11029
Location: Australia
Does your PCB have these components?

Attachment:
fuse.jpg
fuse.jpg [ 378.92 KiB | Viewed 1374 times ]


I don't know the baud rate settings. You'll need to discover those for yourself. Sorry.

_________________
A backup a day keeps DR away.


Top
 Profile  
 
 Post subject: Re: Conner CP 2064 head issue
PostPosted: September 3rd, 2018, 18:26 
Offline

Joined: September 3rd, 2018, 14:52
Posts: 10
Location: Almere/The Netherlands
It does have those components (see attachment) but the "fuse" seems to be fine. One of the diodes, however seems broken, it measures at ~47KOhms in both directions.

I've been experimenting with different pin configurations and baudrates but no dice (yet).

What's strange to me is that the drive works fine when the actuator is "helped" on startup. If you just leave it the chip marked ZNC492GP3 gets really hot, haven't checked just how hot yet.

I'll try some more tomorrow, as it is getting late here.


Attachments:
20180904_001942.jpg
20180904_001942.jpg [ 5.51 MiB | Viewed 1367 times ]
Top
 Profile  
 
 Post subject: Re: Conner CP 2064 head issue
PostPosted: September 3rd, 2018, 18:32 
Offline
User avatar

Joined: September 8th, 2009, 18:21
Posts: 11029
Location: Australia
It's in Russian ...
http://www.acelab.ru/dep.pc/doc.pc3000dos/050530.001/Pcconer.pdf

_________________
A backup a day keeps DR away.


Top
 Profile  
 
 Post subject: Re: Conner CP 2064 head issue
PostPosted: September 3rd, 2018, 18:50 
Offline
User avatar

Joined: September 8th, 2009, 18:21
Posts: 11029
Location: Australia
I have done some Conner PCB work here:
http://www.hddoracle.com/viewtopic.php?f=112&t=2403

At that time I thought that the ZNC492GP3 chip was a read/write channel, but if I'm right, then I can't understand why it would be getting hot. If anything, I would expect that the motor controller would heat up. :?

_________________
A backup a day keeps DR away.


Top
 Profile  
 
 Post subject: Re: Conner CP 2064 head issue
PostPosted: September 4th, 2018, 7:21 
Offline

Joined: September 3rd, 2018, 14:52
Posts: 10
Location: Almere/The Netherlands
I've found a pin that should be RS232 Tx, but I can't get any sensible data from it at any baudrate.

I'm interested as to why you'd expect the motor controller to heat up as the drive spins up just fine, it's just the actuator not moving from the parked position on it's own, which leads me to beleive the chip heating up is what controls the actuator.


Top
 Profile  
 
 Post subject: Re: Conner CP 2064 head issue
PostPosted: September 4th, 2018, 7:42 
Offline

Joined: September 3rd, 2018, 14:52
Posts: 10
Location: Almere/The Netherlands
Decided to try something else.
Since the actuator wouldn't move from it's parked position and since it is kept there by a magnet I decided to remove the magnet to see if the actuator is somehow underpowered. No results so I put it back. I'm starting to wonder if the PCB might somehow be at fault here.

Basically the same shape as before, spins up OK, then spins down. If I move the actuator from it's parked position ever slightly during powerup (but after spinup though) the drive works fine and MS-DOS boots.


Top
 Profile  
 
 Post subject: Re: Conner CP 2064 head issue
PostPosted: September 4th, 2018, 16:24 
Offline
User avatar

Joined: September 8th, 2009, 18:21
Posts: 11029
Location: Australia
In current HDDs the motor controller is a "combo" chip that controls the spindle, voice coil and power supplies. Therefore one might expect this chip to heat up when the spindle is seized or if there is a problem with the VCM. That said, in your case there are 4 discrete MOSFET drivers (Si9956DY), so my observation would probably not apply to your drive.

The Cirrus Logic 61136-1 chip would be either the spindle motor controller or VCM controller, or both. I don't know if the S-MOS chip (61137-001) is also a controller of some kind. If I were attacking this problem, I would trace the circuit involving those 4 chips and the HDA connector, and I would determine which pins of the Cirrus Logic chip drive the gates of the MOSFETs. The functions of the diodes might be important as well, especially if one of them is leaky.

Si9956DY, Siliconix, Dual N-Channel MOSFET, 20V, 3.5A:
http://www.vishay.com/docs/70140/70140.pdf

Attachment:
Si9956DY_pinout.gif
Si9956DY_pinout.gif [ 8.18 KiB | Viewed 1241 times ]

As for the terminal, have you matched the TTL voltage levels? Measure the voltages at the drive's Tx/Rx pins and those of your adapter. According to the following URL, your drive should identify itself as a Sahara.

Conner Families:
http://www.9to5computer.com/9-5/Hard%20Drive%20Inf/conner.htm

_________________
A backup a day keeps DR away.


Top
 Profile  
 
 Post subject: Re: Conner CP 2064 head issue
PostPosted: September 4th, 2018, 17:50 
Offline

Joined: September 3rd, 2018, 14:52
Posts: 10
Location: Almere/The Netherlands
I see, will try to trace the circuit connected to those mosfets.

I have matched the TTL levels for the rx/tx pins (they're at 5v) and tried using both an arduino nano and a generic USB to TTL converter, both gave the same results.
I tried a Seagate drive I have and it worked fine using the same configuration.

I did make some progress exploring options today, I tried reading the terminal port with the PCB disconnected from the HDA (which didn't really change anything) and after reassembly the drive tries to move the heads on startup which is more than it did before. No idea how, but it's a major difference.

Emphasis on tries though, I've tried to flip the magnet latching the actuator which worked about 2-3 times.
Figuring the assembly might be partially magnetised because the drive hasn't been used in years I tried to partially demagnetize the tiny 2x2x1.5mm neodynium magnet and, well.... let's just say it's not a magnet anymore (oops).
I ordered an identical new magnet that should be delivered thursday.

Failing that I've got an option of buying an identical drive with mechanical failure but known good PCB for cheap so I might take that road, could also be good for interchanging some other parts, who knows.

Thanks for the help so far, I'll update when/if I find something new.


Top
 Profile  
 
 Post subject: Re: Conner CP 2064 head issue
PostPosted: September 4th, 2018, 20:36 
Offline
User avatar

Joined: September 8th, 2009, 18:21
Posts: 11029
Location: Australia
FWIW, on another CP2064 PCB the Cirrus Logic 61136-1 IC is labelled as "Conner GC45D 61136-001", but it is in fact the same chip.

This document ...

https://www.leagle.com/decision/19962392946fsupp144612224

... calls it a "GC 45 D-Servo" with Cirrus Logic identified as the manufacturer.

_________________
A backup a day keeps DR away.


Top
 Profile  
 
 Post subject: Re: Conner CP 2064 head issue
PostPosted: September 4th, 2018, 20:41 
Offline
User avatar

Joined: September 8th, 2009, 18:21
Posts: 11029
Location: Australia
Could it be that there is a break in the flex cable that causes the VCM circuit to be open when parked but closed when disturbed??? Or could there be, or have been, high resistance in the HDA connections?

_________________
A backup a day keeps DR away.


Top
 Profile  
 
 Post subject: Re: Conner CP 2064 head issue
PostPosted: September 4th, 2018, 21:58 
Offline
User avatar

Joined: September 8th, 2009, 18:21
Posts: 11029
Location: Australia
FuST wrote:
I have matched the TTL levels for the rx/tx pins (they're at 5v) and tried using both an arduino nano and a generic USB to TTL converter, both gave the same results.
I tried a Seagate drive I have and it worked fine using the same configuration.

Could Conner be using some special protocol? Alternatively, could the levels be inverted? You could compare the Tx states of your Seagate and Conner drives when the channel is idle.

_________________
A backup a day keeps DR away.


Top
 Profile  
 
 Post subject: Re: Conner CP 2064 head issue
PostPosted: September 5th, 2018, 2:35 
Offline
User avatar

Joined: September 8th, 2009, 18:21
Posts: 11029
Location: Australia
FuST wrote:
I've read the thread you posted but cannot figure out how to physically connect to the debug port (it's a 2.5" drive btw)

I believe this is the adapter that the other thread refers to:

PC-2" adapter intended for connecting 2,5" and 1,8" HDDs:
https://www.acelaboratory.com/images/PC3000Portable_PC2.jpg

AIUI, the PC3000 card connects to the 40-pin IDE, the 2.5" drive to the 44-pin IDE + 4-pin jumper receptacle, and the PC-terminal port to the PC-KALOK header.

IDE pin #1 is Reset, so control of this function is transferred to the KALOK port. The adapter's two 2x3 jumper blocks configure the Rx and Tx pins by selecting 1 of 4 inputs from the HDD's own jumper block.

Therefore ISTM that there is no level inversion.

_________________
A backup a day keeps DR away.


Top
 Profile  
 
 Post subject: Re: Conner CP 2064 head issue
PostPosted: September 11th, 2018, 18:40 
Offline

Joined: September 3rd, 2018, 14:52
Posts: 10
Location: Almere/The Netherlands
I'm pretty sure I got the serial port right, but it seems to be a proprietary protocol, not ASCII.

As for the magnets I ordered, they are the wrong size.
I ordered new magnets that should fit but they have to be shipped from hong kong so it'll take a while.

Will update when I know more.


Top
 Profile  
 
 Post subject: Re: Conner CP 2064 head issue
PostPosted: September 11th, 2018, 18:45 
Offline
User avatar

Joined: September 8th, 2009, 18:21
Posts: 11029
Location: Australia
FuST wrote:
I'm pretty sure I got the serial port right, but it seems to be a proprietary protocol, not ASCII.

Is it possible that there is a grounding problem? That is, do you need to run a ground wire to your adapter?

_________________
A backup a day keeps DR away.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 21 posts ]  Go to page 1, 2  Next

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: Google Adsense [Bot] and 34 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group