Switch to full style
Data recovery and disk repair questions and discussions related to old-fashioned SATA, SAS, SCSI, IDE, MFM hard drives - any type of storage device that has moving parts
Post a reply

HTS541010A7E630 - Strange Drive

May 15th, 2019, 15:25

I had a 3 years old case same model. Writing with a new case.

In past, I received 3-4 pcs of this model.
Symptom # DRIVE READY IN 2-3 SECONDS. but no detection. Once we try UTILITY, then drive IDs, shows SN, FW but capacity 0. Once we try to see NVRAM, it shows wrong head map.I tested on good and bad drive. In both case its wrong headmap.

If we try to hear the internal behaviour, we can hear its spinning very nice and smooth. No abnormal noise, but drive doesn't calibrate. If we go for precise hearing, the head actually doesnt move from ramp, it stays in ramp. I have opened a hdd earlier with similar symptom and behaviour, exactly same what I noticed.

PS # There is no exact utility for this model but we use 5450A7 utility for this case.

To solve this issue, we tried different combination, but all the cases were unsuccessful.
1. We tried PCB Replacement, same
2. HSA SWAP, it remains same.
3. Tried to read SA, but inaccessible.

Have you ever faced this model with such situation?


Today, I have another new case with exactly same behaviour. Tried LDR with same model, still SA is ubreadable.

Whats your experience?

Re: HTS541010A7E630 - Strange Drive

May 15th, 2019, 16:31

Selected family......................... : 5450A7
Model by ID............................. : <ID IS NOT READ>

Techno mode key......................... : Error
ROM reading...
Possible Tech Key is found. Checking...
Result.................................. : Ok

Error executing command: Reading SA [0x3F0000004, 0x4]
Device error detected "ABR"
Error reading module USAG(0): Error executing command: Reading SA [0x3F0000004, 0x1]
Device error detected "ABR"
Error executing command: Reading SA [0x3F0100004, 0x4]
Device error detected "ABR"
Error reading module USAG(1): Error executing command: Reading SA [0x3F0100004, 0x1]
Device error detected "ABR"
Loading modules table................................................. : Error
Error : .............................................................. : Module USAG: no copies read!
Loading the table of "open" modules................................... : Error
Error : .............................................................. : Error executing loading "open" modules dir comma

Re: HTS541010A7E630 - Strange Drive

May 15th, 2019, 16:33

Techno mode key......................... : Error

Looks like the utility doesn't know the "super on" for that model of drive and because of that it will not read SA ...

Try with good drive from same model ! Does it read SA ? Bet not ...

Re: HTS541010A7E630 - Strange Drive

May 15th, 2019, 17:02

Spildit wrote:Techno mode key......................... : Error

Looks like the utility doesn't know the "super on" for that model of drive and because of that it will not read SA ...

Try with good drive from same model ! Does it read SA ? Bet not ...


From good HDD, it reads SA. I have tested several months ago, At this moment I don't have good drive in hand to test and update you. Possibility in 2-3 days I can reconfirm you

Re: HTS541010A7E630 - Strange Drive

May 15th, 2019, 17:36

Looks like PC-3000 gets the super on from the ROM ...

ROM reading...
Possible Tech Key is found. Checking...
Result.................................. : Ok



Maybe your MAIN ROM code is damaged in a way that PC-3000 can't use the super on.

Read SA from same model of HDD. When you do so swap the drive without closing utility. Try to read SA from bad drive. PC-3000 should "know" the SUPER ON as it grabbed it from the ROM of donor ...

Re: HTS541010A7E630 - Strange Drive

May 16th, 2019, 0:04

It's a wild idea, but is it possible that there was a VCM fault which caused both the VCM and the PCB's VCM drive electronics to go open circuit? This could explain why replacing only one of these items didn't change the symptoms. Perhaps you should replace both the PCB and headstack at the same time?

Re: HTS541010A7E630 - Strange Drive

May 16th, 2019, 0:35

Could this be one of those models where the NVRAM becomes corrupt (even though its checksum is valid)???

Re: HTS541010A7E630 - Strange Drive

May 16th, 2019, 2:41

Spildit wrote:Looks like PC-3000 gets the super on from the ROM ...

ROM reading...
Possible Tech Key is found. Checking...
Result.................................. : Ok



Maybe your MAIN ROM code is damaged in a way that PC-3000 can't use the super on.

Read SA from same model of HDD. When you do so swap the drive without closing utility. Try to read SA from bad drive. PC-3000 should "know" the SUPER ON as it grabbed it from the ROM of donor ...


Though wild idea but will try for sure.

Can we adjust the ROM code from a donor and see?

fzabkar wrote:Could this be one of those models where the NVRAM becomes corrupt (even though its checksum is valid)???


It can be!

NVRAM attached
Attachments
NV-RAM.zip
(2.4 KiB) Downloaded 51 times

Re: HTS541010A7E630 - Strange Drive

May 17th, 2019, 23:07

What is point to check SA reading if heads doesn't move?

Re: HTS541010A7E630 - Strange Drive

May 18th, 2019, 3:15

@drHDD, Can you shed light what to do?
Did you see similar case in this model?

Re: HTS541010A7E630 - Strange Drive

May 18th, 2019, 17:20

I had similar problem, but changing heads helped.

Re: HTS541010A7E630 - Strange Drive

June 3rd, 2019, 9:50

Hi! If I may - I am adding myself to this thread because I have the same problem on my desk right now. I already swapped the HSA but the behaviour stays the same.
@shahij: did you solve the problem?

Re: HTS541010A7E630 - Strange Drive

June 6th, 2019, 23:00

Try to change pcb.
Post a reply