All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 7 posts ] 
Author Message
 Post subject: WD mybook WD80EZAZ-11TDBA0 no power masked ROM?
PostPosted: September 9th, 2019, 3:58 
Offline

Joined: August 8th, 2007, 6:32
Posts: 1209
Location: inside ROM
I have a WD mybook WD80EZAZ-11TDBA0 it has no power,is the rom now masked to main processor? I have cover the 3.3V pin hoping it will work but it doesnt work. in PC3000 12V rail line error, 5V line is ok.

There is a HX marking components which was damage, probably fuse?

Any help much appreciated.


Attachments:
IMG_0109.JPG
IMG_0109.JPG [ 3.33 MiB | Viewed 270 times ]
Top
 Profile  
 
 Post subject: Re: WD mybook WD80EZAZ-11TDBA0 no power masked ROM?
PostPosted: September 9th, 2019, 4:10 
Offline

Joined: May 21st, 2007, 16:10
Posts: 1554
Location: Gothenburg/ Sweden
Is not the ROM where I marked in red?


Attachments:
IMG_0109.JPG
IMG_0109.JPG [ 3.69 MiB | Viewed 264 times ]

_________________
Rescue IT Datarecovery service Sweden
Rescue IT Dataräddning Göteborg AB
http://www.rescue-it.se
Top
 Profile  
 
 Post subject: Re: WD mybook WD80EZAZ-11TDBA0 no power masked ROM?
PostPosted: September 9th, 2019, 5:06 
Offline
User avatar

Joined: September 8th, 2009, 18:21
Posts: 11714
Location: Australia
Check the 12V TVS diode and its associated fuse.


Attachments:
TVS_diodes_fuses.jpg
TVS_diodes_fuses.jpg [ 295.95 KiB | Viewed 253 times ]

_________________
A backup a day keeps DR away.
Top
 Profile  
 
 Post subject: Re: WD mybook WD80EZAZ-11TDBA0 no power masked ROM?
PostPosted: September 9th, 2019, 5:17 
Offline
User avatar

Joined: September 8th, 2009, 18:21
Posts: 11714
Location: Australia
mr_spokk wrote:
Is not the ROM where I marked in red?

Yes.

http://www.hddoracle.com/viewtopic.php?f=21&t=2549&p=20305#p20305

_________________
A backup a day keeps DR away.


Top
 Profile  
 
 Post subject: Re: WD mybook WD80EZAZ-11TDBA0 no power masked ROM?
PostPosted: September 9th, 2019, 7:40 
Offline

Joined: August 8th, 2007, 6:32
Posts: 1209
Location: inside ROM
Thank you Guys, will check it out


Top
 Profile  
 
 Post subject: Re: WD mybook WD80EZAZ-11TDBA0 no power masked ROM?
PostPosted: September 9th, 2019, 16:18 
Offline
User avatar

Joined: September 8th, 2009, 18:21
Posts: 11714
Location: Australia
Please do tell us how you go replacing the diode and fuse. It should be a 5-minute job.

_________________
A backup a day keeps DR away.


Top
 Profile  
 
 Post subject: Re: WD mybook WD80EZAZ-11TDBA0 no power masked ROM?
PostPosted: September 9th, 2019, 21:32 
Offline

Joined: August 8th, 2007, 6:32
Posts: 1209
Location: inside ROM
Done, replaced 12V TVS and a fuse, luckily the HDA is still ok. thanks again for your help Spokk & Fzabkar


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: Google [Bot] and 22 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group