All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: IBM DLGA-23080 from a 1997 ThinkPad - security, unlocking
PostPosted: February 20th, 2021, 8:05 
Offline

Joined: February 20th, 2021, 6:59
Posts: 1
Location: Poland
Hello folks!

First off, I'd like to applaud you for being such an expansive and informative bunch. This motherlode of a forum provides great information about all of the inner workings of our old spinning friends, and I spent many a hours just simply browsing the forum and reading about stuff. You've put a lot of effort - especially some select members - and your dedication deserves much kudos.

To the subject:
I was contacted by a good friend of mine. He told me about an old ThinkPad he thought was long gone, but alas - it was re-discovered in his attic. It's a ThinkPad 380ED from 1997 - a "reward" he got from his work in geodesy after it was decommissioned somewhere in 2002-3. He then used it for a bit for himself, then bought a new laptop... the old ThinkPad was left collecting dust. Upon re-discovering it he eagerly bought a power supply and got to booting it up, only to be meet by a lock screen. He then turned to my help.

Now, when I got it, I thought this was the good old supervisor password issue - having some experience with unlocking ThinkPads of this era I saw it as no problem, yet I didn't expect that it wasn't the supervisor password, but a hard drive password, as swapping the drive for another gives me a clean boot without any problems. The drive in question is (quoting HDSentinel) an IBM DLGA-23080 from the Travelstar 3XP family, 3080MB capacity. Datecode is September 1997. It has no Travelstar branding on its label, though.

I am intrigued by the safety measures of the drive - why does it act the way it does? I tried putting it in a period-correct machine with a true IDE controller - a Pentium II PC.
Upon connecting to it with a 44pin IDE adapter I initially got nothing, it wouldn't even spin up - until I discovered that my adapter does not have pin 41 connected (+5V logic)! Running a wire from it to pin 42 (+5V motor) fixed the issue - and additionally made one old 2,5 drive of mine spin up and work in this PC. After the fix the ThinkPad hard drive is detected in BIOS properly, albeit it gives the good old "DISK BOOT FAILURE. INSERT SYSTEM DISK AND PRESS ENTER" message. I do not get any password prompt.

I do already have one vintage, slightly modified ThinkPad - a 560X - that I use to move data out and about between my retro computers and as a "hub" for formatting and prepping IDE drives. Upon placing this drive in it I get the password prompt with 3 tries, same as if I put it in the "original" ThinkPad 380ED.

Did IBM use some sort of special locking measures in ThinkPads, so as to make the drive in-unlockable from any other computer than ThinkPads? Has anyone had experience with this? Or perhaps is it something wrong that I'm doing and this behavior shouldn't happen?

As for the data, since I'm aware that this is a very touchy issue - the friend does not really care for the data, as it arrived, in his words, "factory-formatted". He does however care about the factory programs that IBM supplied with the laptop, wallpapers and screensavers, and all. He envisions this ThinkPad as a gateway to the world of retro computing and would surely like a versatile, portable retro machine like this. I do have permission from that friend to do "anything" with the drive - I asked him that if push comes to shove I could format the drive and I was given the green light.

I haven't done much with unlocking yet. I did obtain ZU - the latest version - and tried it only to be met with no success. I am not too sure about what "safe mode" should I go for with this drive - the jumper or disconnecting the PCB, for starters. Connecting it without any safe mode enabled and running ZU (bootable floppy with FreeDOS, no other hard drives are connected, only the ThinkPad HDD, I rebooted the PC between every ZU attempt) produces these results:

* zu /p
A50D52 IBM-DLGA-23080
NOT SUPPORTED

* zu /p8
(The hard drive spins down.)
NOW YOU CAN SCREW IT IN. PRESS ANY KEY WHEN READY
(I press any key, and...)
UNLOCK NOT DONE

* zu /p.
HDD=HGST/IBM
UNLOCK NOT DONE

Putting a jumper in the safe mode produces the same results. The /p8 message is the most interesting to me. Does ZU produce this message regardless whether a Hitachi or an another manufacturer drive is connected, or is this an indicator that this is a Hitachi drive after all and I'm going in the right direction? I was keen to believe the latter, and thus I unscrewed a few screws from the opposite end of the drive (not from the connector side) and inserted a piece of paper, as many have suggested in this forum. The results:

* POST does not detect the drive anymore. The disk however "clicks" slightly upon loading DOS.

* zu /p8: a very audible noise (a sort of a beep going down in pitch) plays three times. Then a lower pitch noise plays another three times. An "ELAPSED" message appears, and nothing happens. I left the drive for 10 minutes and it still stayed at that "elapsed" message.

And that's it. The situation is not as straightforward as I expected having read many cases of successful unlocks with ZU. So, have some questions:

- Is this an IBM/HGST drive, or a "NativeHitachi" drive? I have trouble recognizing between the two, and this is crucial in obtaining the proper safe mode strategy.

- Should I unscrew the entire PCB? I have not yet looked at what is under it.

- Perhaps there is another way, like shorting some pads or NVRAM?

- Does ZU even support drives this old? Could be that it simply doesn't, right?

I thank you in advance for any suggestions/guiding lights. Cheers!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 37 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group