All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 23 posts ]  Go to page Previous  1, 2
Author Message
 Post subject: Re: Samsung SSD 850 EVO
PostPosted: June 2nd, 2019, 4:47 
Offline

Joined: January 30th, 2013, 11:22
Posts: 12
Location: Sweden
Then hot adding the SSD disk

[ 382.097821] ata5: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[ 382.098107] ata5.00: ACPI cmd f5/00:00:00:00:00:00 (SECURITY FREEZE LOCK) filtered out
[ 387.269789] ata5.00: qc timeout (cmd 0x27)
[ 387.269799] ata5.00: failed to read native max address (err_mask=0x4)
[ 387.269800] ata5.00: HPA support seems broken, skipping HPA handling
[ 392.621743] ata5: link is slow to respond, please be patient (ready=0)
[ 397.305726] ata5: COMRESET failed (errno=-16)
[ 402.657695] ata5: link is slow to respond, please be patient (ready=0)
[ 407.337666] ata5: COMRESET failed (errno=-16)
[ 412.689633] ata5: link is slow to respond, please be patient (ready=0)
[ 442.357439] ata5: COMRESET failed (errno=-16)
[ 442.357448] ata5: limiting SATA link speed to 1.5 Gbps
[ 447.409414] ata5: COMRESET failed (errno=-16)
[ 447.409423] ata5: reset failed, giving up


Top
 Profile  
 
 Post subject: Re: Samsung SSD 850 EVO
PostPosted: April 27th, 2020, 13:01 
Offline

Joined: April 27th, 2020, 12:26
Posts: 2
Location: Ukrain
bital wrote:
sourcerer wrote:
The EVO 840 (predecessor of your model) provides a SAFE mode where you can also do a firmware update through SATA.
(The third method is theoretically through the UART interface, but it's too unstable to be usable)
Additionally we developed a firmware update method through JTAG.

You might be interested in trying my SSD diagnostic tool https://github.com/thesourcerer8/SSDdiag , it has not been ported to EVO850 yet, but it might give some insight anyway, since most of the hardware in the controller is still the same.

I'm having:
SAMSUNG SSD 840 EVO 1TB, still able to boot in SAFE MODE with FIRMWARE: UNKNOWN
SAMSUNG SSD 840 EVO 120GB, in good standing with FIRMWARE: EXT0DB6Q

SAMSUNG SSD 840 EVO 120GB, EXT0DB6Q, I was able to upgrade from EXT0BB6Q to EXT0DB6Q by this command in REGULAR MODE
Code:
hdparm --yes-i-know-what-i-am-doing --please-destroy-my-drive --fwdownload EXT0DB6Q /dev/sda

so, the process is kind of working to upgrade the firmware, while I'm trying to move from EXT0DB6Q to EXT0BB6Q back it gives me this kind of error:
Code:
hdparm --yes-i-know-what-i-am-doing --please-destroy-my-drive --fwdownload EXT0BB6Q /dev/sda
/dev/sda:
fwdownload: xfer_mode=3 min=1 max=2048 size=512
...............................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................SG_IO: bad/missing sense data, sb[]:  70 00 05 00 00 00 00 0a 04 51 e0 00 21 04 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
. Done.

I'm trying to upgrade SAMSUNG SSD 840 EVO 1TB, still able to boot in SAFE MODE with FIRMWARE: UNKNOWN to EXT0BB6Q or EXT0DB6Q with the same result of sda hanging and not answering anymore forcing to shut down by holding power for 5 sec
I have this message and stuck
Code:
/dev/sda:
fwdownload: xfer_mode=3 min=1 max=2048 size=512
...............................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................

Ordered Altera USB Blaster cable...

Any ideas?

I haw got also: SAMSUNG SSD 840 EVO 1TB, still able to boot in SAFE MODE with FIRMWARE: UNKNOWN, serial number 0000000000
SAMSUNG SSD 840 EVO 750GB still able to boot in SAFE MODE with FIRMWARE: UNKNOWN, serial number 0000000000
and I have almost the same proble. I haven't been done result with HDPARM fwupgrade. What about your results? Have you ever used jtag and Altera usb blaster?


Top
 Profile  
 
 Post subject: Re: Samsung SSD 850 EVO
PostPosted: April 27th, 2020, 13:20 
Offline

Joined: April 27th, 2020, 12:26
Posts: 2
Location: Ukrain
[quote="sourcerer"]The EVO 840 (predecessor of your model) provides a SAFE mode where you can also do a firmware update through SATA.
(The third method is theoretically through the UART interface, but it's too unstable to be usable)
Additionally we developed a firmware update method through JTAG.
Can you tell me more about JTAG method? I have Altera usb blaster but I have not fined information yet how to use it practically.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 23 posts ]  Go to page Previous  1, 2

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 19 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group