All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Wrong PSU cable, melted SATA cable, SSD not working
PostPosted: May 20th, 2020, 0:47 
Offline

Joined: May 20th, 2020, 0:37
Posts: 1
Location: Qu├ębec
Hi! The wrong modular PSU cable was connected to the SSD and the sata data cable started to smoke and melt. The SSD is not working anymore and not recognized. There is no visible damage on the PCB and nothing gets hot while plugged. I know a thing or two about electronics and data recovery but not much with SSDs. Where should I start? What should I test first? Any hope it can be recovered?

Thank you!


Top
 Profile  
 
 Post subject: Re: Wrong PSU cable, melted SATA cable, SSD not working
PostPosted: May 20th, 2020, 4:17 
Offline
User avatar

Joined: September 8th, 2009, 18:21
Posts: 12371
Location: Australia
TVS Diode FAQ:
http://www.hddoracle.com/viewtopic.php?f=100&t=86

Protection Devices - Electronic Fuse:
http://www.hddoracle.com/viewtopic.php?f=100&t=1615&p=8872#p8872

_________________
A backup a day keeps DR away.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group