All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 10 posts ] 
Author Message
 Post subject: Need Hitatchi firmware
PostPosted: July 14th, 2018, 19:23 
Offline

Joined: July 14th, 2018, 19:18
Posts: 5
Location: United States
Hello,

Trying to track down firmware for the following hitatchi drives:
HUA721010KLA330
HDE721010SLA330

I've done some extensive research to see if I could track down firmware. I did find some potential firmware for HUA721010KLA330, but it's dell firmware and unsure how that will work, if at all. Just for reference for any looking, I found the firmware from the link below:
https://www.dell.com/support/home/us/en ... erid=kd2f4
I'm willing to give that firmware a chance and just JTAG the PCB later if the firmware bricks the drive.

Any hitatchi firmware version will work for my needs, though I prefer newest firmware if possible. They currently have custom firmware on them which locks the drives to only negotiate 1.5gbps link speeds which my HBA won't support.

Thanks!


Top
 Profile  
 
 Post subject: Re: Need Hitatchi firmware
PostPosted: July 14th, 2018, 21:07 
Offline
User avatar

Joined: September 8th, 2009, 18:21
Posts: 10854
Location: Australia
A drive's firmware consists of many modules. Only a few of these modules would be targeted by an update. I suspect that in your case you would be looking at the FEAT (features?) module.

Alternatively, there could be a configuration setting in the NVRAM on the PCB.

You might like to investigate "Niagara":
http://files.hddguru.com/download/Software/HGST/

Edit: You might be able to achieve your ends with Hitachi's Feature Tool:
https://www.hgst.com/support/hard-drive-support/downloads/legacy-downloads

Quote:
Warning! Switching your drive to support 3.0Gb/s, or enabling spread spectrum clocking and then using it, may render your drive unusable in a system that cannot support these functions. If in doubt, please contact your system manufacturer.

_________________
A backup a day keeps DR away.


Top
 Profile  
 
 Post subject: Re: Need Hitatchi firmware
PostPosted: July 14th, 2018, 22:40 
Offline

Joined: July 14th, 2018, 19:18
Posts: 5
Location: United States
I will check out the suggested took asap.

As far as the feature tool, I can't get it to detect my drive. I dont have hardware old enough for it to detect my drive correctly.

Thanks!


Top
 Profile  
 
 Post subject: Re: Need Hitatchi firmware
PostPosted: July 15th, 2018, 4:57 
Offline
User avatar

Joined: December 19th, 2006, 8:49
Posts: 9687
Location: Portugal
What is your goal ? To set the SATA speed only ???

For IBM based drives including newer HGST ARM you can set the speed of the SATA link using a vendor specific command...

You don't need to flash anything and i trully doubth that flashing firmware would help you out as the update wouldn't change the drive configuration no matter if it's stored on NVRam or FEAT ...

Attachment:
1.jpg
1.jpg [ 57.04 KiB | Viewed 1292 times ]

_________________
1Q9xrDTzTddUXeJAFRn37aqh1Yr6buDCdw - (Bitcoin Donations)
paypal.me/Spildit - (PayPal Donations)
The HDD Oracle - Platform for OPEN research on Data Recovery.


Top
 Profile  
 
 Post subject: Re: Need Hitatchi firmware
PostPosted: July 15th, 2018, 11:07 
Offline

Joined: July 14th, 2018, 19:18
Posts: 5
Location: United States
Hello,

@fzabkar; Checked out Niagara and while I'm pretty sure I found the right section to set link speed, it seems to have failed:
Code:
CMD: A1 06 20 54 02 00 C7 A9 00 8F 00 00

     FE SC LL LM LH DH CM 
ATA: 54 02 00 C7 A9 00 8F

Error (0 ms) At 08:56:52 07/15/18

<E> Check Condition:

Info: Command Returned 0 bytes

70 00 0B 00 00 00 00 0A 00 00 00 00 00 00 00 00
00 00

Translation: Aborted Command.  No Additional Sense Code.

For reference, after opening Niagara (spti driver detected my drives) I ensured only the target device was selected, then went to ATA Tools > Set Features > Vendor Unique Features > 0x54: Set SATA Speed Limit > 0x2

@Spildit; Primary goal is to set link speed to 3Gb/s. I was finally able to get the drive to show up to the feature tool from hgst, but it claimed the drive didn't support changing link speed.

So as a note, this drive came out of a NetApp appliance and was previously flashed with NetApp's custom firmware. What all that changes, I'm unsure, but that's the main reason for trying to find stock firmware. I'm not sure I can set the link speed until I've gotten rid of this garbage NetApp Firmware.

Thanks!


Top
 Profile  
 
 Post subject: Re: Need Hitatchi firmware
PostPosted: July 15th, 2018, 11:59 
Offline

Joined: July 14th, 2018, 19:18
Posts: 5
Location: United States
Update! I noticed another feature to "Disable Force Gen 1" for the drive. Executed that successfully on the HDE721010SLA330. I will try it out on some others but that might have been the trick I needed.

I'll also test this on the HUA721010KLA330 when I get home and can swap to the disk.

I'll post some updates later tonight.

Thanks!


Top
 Profile  
 
 Post subject: Re: Need Hitatchi firmware
PostPosted: July 15th, 2018, 12:57 
Offline
User avatar

Joined: December 19th, 2006, 8:49
Posts: 9687
Location: Portugal
Looks like Niagara did use some sort of CDB instead of ATA VSC ...

For the record the ATA VSC that i do use to set SATA speed is not the same as the one you did use.

You used a variant of 8F and i use EF with a completly diferent parameter on error/feature.

_________________
1Q9xrDTzTddUXeJAFRn37aqh1Yr6buDCdw - (Bitcoin Donations)
paypal.me/Spildit - (PayPal Donations)
The HDD Oracle - Platform for OPEN research on Data Recovery.


Top
 Profile  
 
 Post subject: Re: Need Hitatchi firmware
PostPosted: July 18th, 2018, 15:22 
Offline

Joined: July 14th, 2018, 19:18
Posts: 5
Location: United States
Completely forgot to post an update. Niagara did the trick, same advanced option for both drives to disable force gen 1.


Top
 Profile  
 
 Post subject: Re: Need Hitatchi firmware
PostPosted: July 18th, 2018, 16:08 
Offline
User avatar

Joined: September 8th, 2009, 18:21
Posts: 10854
Location: Australia
Thanks for the feedback.

_________________
A backup a day keeps DR away.


Top
 Profile  
 
 Post subject: Re: Need Hitatchi firmware
PostPosted: July 18th, 2018, 18:30 
Offline
User avatar

Joined: December 19th, 2006, 8:49
Posts: 9687
Location: Portugal
Cool ! Nice that it did work out for you !

_________________
1Q9xrDTzTddUXeJAFRn37aqh1Yr6buDCdw - (Bitcoin Donations)
paypal.me/Spildit - (PayPal Donations)
The HDD Oracle - Platform for OPEN research on Data Recovery.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group