All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Serial Console Ctrl Z Not Working
PostPosted: June 4th, 2019, 13:12 
Offline

Joined: June 4th, 2019, 12:57
Posts: 2
Location: New York
Hello all!

Recently I have been trying to practice some disk forensics on a HDD that a company shipped out to me, and I've found myself a little stumped. The issue I'm running into is essentially my home system can no longer recognize the HDD (at POST, nothing happens) so I'm assuming that I have a BSY error going on. I've been able to get a serial console working by using an FT232 chip and putty connection on COM port 9 (with windows) or /dev/ttyUSB0 on linux.

Previously, the HDD was able to mount successfully onto windows and I was able to recover flash software as well as the correct .lod files for firmware flashing, but at some point, the HDD became unusable via normal SATA/USB connection.

The issue I'm running into now is that in the serial console (tx/rx 4 pin connection), there is custom code running with a continuous message telling me to "patch me!" that I believe is interfering with the ctrl+z method to open console controls. I believe that the tx connection from the FT232 device is working (there's a small blipping light everytime I press a keyboard function while connected to the console). The problem with this is that in order to patch (I believe) I need to flash .lod firmware onto the drive, but because it's BSY, I can't mount it to /dev/sg# nor does windows recognize it as a device.

Is there anyway to force a ctrl+z signal to the console? Or am I locked out for good here? Are there any tools that can further examine the serial port aside from, or ontop of PuTTy?

THE HDD:
Model No. Seagate ST3160318AS

PCB :
SATA + 4pin serial connector (tx,rx,gnd,bitspeed)

FT232 connection:
https://tinkersphere.com/electronic-com ... elper.html
baud : 38400

PCB ---- FT232 => laptop
tx . ----- . rx
rx . ----- . tx
gnd . --- . gnd
. ---X


Top
 Profile  
 
 Post subject: Re: Serial Console Ctrl Z Not Working
PostPosted: June 6th, 2019, 13:53 
Offline
User avatar

Joined: December 19th, 2006, 8:49
Posts: 10763
Location: Portugal
- You shouldn't PRACTICE with drives that you care for and that you do need the data from.

- 7200.12 drives as yours don't have the LBA-0/BSY issue that 7200.11 drives do and if you run the internet fix on 7200.12 drives you will end up at best with partial access to LBA...

- If the drive was detected correctly there shouldn't be any need to flash anything or get loaders. You could had disabled stuff with congen to facilitate recovery. Apart from that it does look like you did mess up big time.

- That "patch me" thing ... It does look like you don't have a clue about what you are doing ... Hopefully you didn't brick the ROM ... If you somehow did erase the ROM and what you are getting is the boot code mode forget about getting data out of that drive as ROM is unique ...

- You would be way better off with decent firmware tools like PC-3000, MRT or at least SeDiv ...

I don't know what sort of "forensics" you did intend to do on the drive but it does look like you did mess it up for good ...

Sorry ...

_________________
1Q9xrDTzTddUXeJAFRn37aqh1Yr6buDCdw - (Bitcoin Donations)
paypal.me/Spildit - (PayPal Donations)
The HDD Oracle - Platform for OPEN research on Data Recovery.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group