Switch to full style
Tools for hard drive diagnostics, repair, and data recovery
Post a reply

Hitachi 7k1000.C 1TB HDT721010SLA360 FIRMWARE UPDATE

March 9th, 2012, 1:45

I have an older Hitachi with the original shipping firmware that needsto be flashed. It's a 7k1000.C 1TB HDT721010SLA360 drive with original shipping 31b firmware/microcode.

I have tried to flash it with HiTest but it doesn't seem to work IE it can't see the drive. The system is an AHCI P67-B3 board. I really don't want to boot into windows in IDE mode... That software is very convoluted for managing CRM on HD returns or something...

It seems to have microcode 31b from this device string.


I also read somewhere that I need to upate the firmware/microcode in sequence of release. It's my understanding the first lease is 31B, the second 39C, the third 3EA and the bloody final version 3MA.

I also understand that these DBX files are specific to the capacity of the drive and I'm not sure I have the right ones.

Also that there are two versions of the DOS flashing utility I can't seem to find that are specific to the size of the drive.

What a ROYAL PITA it is to flash a Hitachi drive...



PS I tried flashing it from dos using JPDL_SP.exe but again even with BIOS in IDE mode it can't see the dam drive! argh!!! I was using SATA3 port 1 on P67A. Should I try port 2 (physical port 3) as it's sata 2 only ? could this be the problem?

Re: Hitachi 7k1000.C 1TB HDT721010SLA360 FIRMWARE UPDATE

March 9th, 2012, 2:07

My mistake it's a .b model... LOL

The .c model is the one of the left dummy...


Re: Hitachi 7k1000.C 1TB HDT721010SLA360 FIRMWARE UPDATE

March 9th, 2012, 8:08

Mine is not to reason why you are updating the firmware, but FWIW I know that Samsung's firmware updater needs to see an IDE port at the legacy ISA port addresses (0x1F0 or 0x170) rather than a PCI port. Perhaps Hitachi's DOS based updater has a similar limitation?

You say that your BIOS is set to IDE mode, but is it "legacy IDE" mode?

Re: Hitachi 7k1000.C 1TB HDT721010SLA360 FIRMWARE UPDATE

January 1st, 2016, 6:31

HiroPro, Hi, I noticed your post about trying to do a firmware update for your HDT721010SLA360 , which you first described as 7K1000.C and then later corrected to 7K1000.B . I am wondering if you ever found any updated firmware for it? I did find the firmware for the 7K1000.C here http://files.hddguru.com/download/Firmware%20updates/Hitachi/ but didn't see anything for the 7K1000.B and I've been trying to figure this out for hours. I have a number of 7K1000.B drives in a raid array with the ST6OA31B firmware and as one has already died suddenly and mysteriously which always reported a Good S.M.A.R.T. health. I really would like to know where updated firmware can be downloaded because perhaps they have addressed the problem in an update. Any help pointing me in the right direction would be appreciated, or if you discovered that there actually was no firmware update for the drive, it would be helpful to know that.

Thank you and Happy New Year!

Re: Hitachi 7k1000.C 1TB HDT721010SLA360 FIRMWARE UPDATE

March 1st, 2019, 23:22

Hi Merlock, and HiroPro,

were you able to obtain firmware updates for the Hitachi 7k1000.B? I have a MacPro with two of these drives, and another Samsung SSD that I recently installed. The two Hitachi Deskstars have been working fine on MacOS El Cap. I recently installed Mac OS High Sierra on the machine, and upon booting to High Sierra, start seeing a disk write error with the following error log: "flushing fs disk buffer returned 0x5". The newer SSD drive has no issues with either OS. Researching on the internet reveals that this is likely a firmware issue, hence looking for a firmware update for the old Deskstars (purchased close to 10 years ago, but not heavily used).

Your response will be extremely helpful!
Post a reply