All times are UTC - 5 hours [ DST ]

Forum rules

Please do not post questions about data recovery cases here (use this forum instead). This forum is for topics on finding new ways to recover data. Accessing firmware, writing programs, reading bits off the platter, recovering data from dust...

Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Toshiba Canvio Basics USB 3.0 Comparing Rev 0000 vs Rev 0001
PostPosted: April 9th, 2013, 3:45 

Joined: April 7th, 2013, 22:06
Posts: 1
Location: Brooklyn, NY
I have two seemingly identical Toshiba Canvio Basics USB 3.0 external drives (model nos. v36700-C, part nos. HDTB110XK3BA).

But one of the drives has synchronization issues when connecting to my gaming console, while the other drive connects seamlessly with no delay. Obviously, I tried switching the included USB-cables already, which had no effect.

The sync issue is something very minor, as it can be immediately resolved by unplugging and replugging the USB-cable between the console and the drive. I was assuming some kind of wakeup or power management setting was incompatible between the two...I wrote it off as poor USB 3.0 backwards compatibility with the specific console to which I was trying to connect. Until I received the second HDD of the same model and noticed right away that there was no sync issue with this drive.

Because of my unique position, having inconsistent results from the two of the same model hard drive, I decided to compare the two drives and see if I could spot any noticeable differences. It will probably turn out to be something beyond my control, like in this forum I found ( ... 24?page=15), where the posters vehemently argue over the hardware used in the external case of my drive (and another similiar model). Many users are claiming that the drive has been manufactured in two formats: one which uses SATA with a USB bridgeboard and another way, where a "native" or "internal" USB connector has been soldered directly to the hard drive. But it's still kind of up in the air whether the "SATA board is actually missing or whether some neat work was done with the PCB to accomodate the USB interface being directly attached." BTW, both my drives have "Made in China," printed on the ID labels.

Short of opening up the drives and voiding the warranty, I checked the device properties in Windows and ran some software analyses, noting a few differences, described below.

The friendly name for the older drive with the sync issues is "TOSHIBA External USB 3.0," while the friendly name for the other is "Toshiba External USB 3.0." The Device Instance Paths and Hardware IDs also vary significantly:

The older drive with the sync issue (referred to hereon as "Rev 0001") is as follows:


While the newer drive that connects with no issues (referred to hereon as "Rev 0000") reads:


I excluded some digits from the Device Instance Paths that are unique to the alleged serial numbers reported by SeaTools, replacing them with # symbols. But the numbers I left present look suspiciously like deployment dates.

The PID and VID from the Parent properties are identical, 0480 and A007 respectively; which seems to be the correct ID for a Toshiba USB 3.0 drive using a known USB-ATA Bridgechip.

Using HDDScan 3.1, I was able to determine that the internal 2.5" drives are both TOSHIBA MQ01UBD100's with firmware AX001U and serial numbers matching those printed on the boxes. I ran Identity Info on each drive and have attached the files herewith.
File comment: Rev 0001 HDDScan v3.1 Identity Report (Before Idle)
Y24-------ID.pdf [99.82 KiB]
Downloaded 549 times

File comment: Rev 0000 HDDScan v3.1 Identity Report
Y25-------ID.pdf [99.99 KiB]
Downloaded 828 times

Rev 0001 is the serial starting with Y24------ (I left out some unique characters again), while Rev 0000 is the serial starting with Y25------. The S.M.A.R.T. reports for each drive vary from each other in minute ways by which I can't really make heads or tails; I uploaded both reports for comparison as well, enclosed herewith.
File comment: Rev 0001 HDDScan v3.1 S.M.A.R.T. Report (Before Idle)
Y24-------SMART.pdf [72.37 KiB]
Downloaded 455 times

File comment: Rev 0000 HDDScan v3.1 S.M.A.R.T. Report
Y25-------SMART.pdf [73.57 KiB]
Downloaded 432 times

And the IDE Features dialog-box, screenshot enclosed herewith,
File comment: Rev 0001 HDDScan v3.1 IDE Features Screenshot (Before Idle)
screenshot_before.png [ 136.67 KiB | Viewed 8548 times ]

for each drive shows Automatic Acoustic Management as Not Supported (white circle), with the options and numbers greyed out; Power Management is Supported (navy blue cricle), with the idle timer set all the way to the left at Disable; and Advanced Power Management is set to On (green circle) with the current value set to 128 - the ticker is in the middle. Spindown and Spinup buttons seem fully functional, taking about 2 and 4 seconds to process on average.

Now here's where things start to get interesting. If I let the drives idle for a while until the operating lights go off, some inconsistencies arise between the two. If I try to run anything from HDDScan, I immediately get an error message from both drives about the semaphore timeout period expiring. Okay, that's understandable, considering the drives were just powered-down. But then when I try to run a S.M.A.R.T. report again, now that the operating lights have resumed, Rev 0000 generates a valid report, while Rev 0001 spits out a dud, enclosed herewith.
File comment: Rev 0001 HDDScan v3.1 Identity Repot (After Idle)
Y24-------ID-DUD.pdf [92.93 KiB]
Downloaded 506 times

The same thing happens when I try to run an Identity Info report on Rev 0001 under the same conditions, also attached herewith.
File comment: Rev 0001 HDDScan v3.1 S.M.A.R.T. Report (After Idle)
Y24-------SMART-DUD.pdf [63.33 KiB]
Downloaded 394 times

And now the IDE Features for Rev 0001 vary from what was originally stated; Power Management is Not Supported (white circle), though the button is not greyed out, and Advanced Power Management is Off (red circle) with the current value set to 0; screenshot enclosed herewith.
File comment: Rev 0001 HDDScan v3.1 IDE Features Screenshot (After Idle)
screenshot_after.png [ 151.85 KiB | Viewed 8548 times ]

But, if I then take a large file from Rev 0001 and copy and paste it to one of my local drives, even though the operating light was already on, I suddenly hear the drive spinning-up and the light begins blinking rapidly while the transfer occurs. And if I generate the reports that had moments before produced duds, I now get full reports as I did when the drive was first plugged in, with even the IDE Features dialog-box reporting the original values. Strange, but reproducible exactly as described above.

And the final piece of the puzzle. SeaTools for Windows v1.2.0.8 (x86) does something very interesting - almost exactly what the gaming console does when it tries to connect to Rev 0001. When the USB-scanning screen appears, even if the drive was just plugged in, even if I force a large file to transfer from the drive concurrently, I hear the device-removal and device-found system noises from Windows just as Rev 0001 is being accessed. And then SeaTools loads, but refuses to generate any information about the drive whatsoever. Leaving ------ in place of it's serial numbers and all the other values blank. But somehow the short DST test passes while in this state. Rev 0000, on the other hand, is accessed/read just fine by SeaTools, and reports can be generated with no problem. The only variance is that SeaTools has reverse-ordered the characters from the final value of the Device Instance Path and reported this as the serial number I have submitted the SeaTools log for each drive for comparison, enclosed herewith.[/color]
File comment: Rev 0001 SeaTools for Windows v1.2.0.8 log
--------.log [1.29 KiB]
Downloaded 331 times

File comment: Rev 0000 SeaTools for Windows v1.2.0.8 log
F######50112102.log [709 Bytes]
Downloaded 318 times

I don't expect to quite correct the issue, but I find the whole comparison intriguing :-? , especially all of the differences. I would love to learn more about what exactly makes Rev 0000 so much more stable than Rev 0001. Could there be a difference in the external closure hardware? Or is it just a difference in the settings? I would love to hear some different opinions on this. I hate leaving something like this open-ended, without at least determining the reason :?: behind all the madness. Any additional insight would be appreciated.

 Post subject: Re: Toshiba Canvio Basics USB 3.0 Comparing Rev 0000 vs Rev
PostPosted: July 11th, 2013, 9:50 

Joined: July 11th, 2013, 6:36
Posts: 2
Location: India
I am new to this forum. You did hell of a research on this HDD. I also have a canvio basics 3.0 500GB. This brand of drives reportedly have an issue regarding excessive power consumption that makes it unusable in new macbooks when plugged into usb 2.0. I use this drive in my PC USB 2.0 and it clicks frequently that i believe due to lack of power. There is no problem with USB 3.0 as it has a much higher power delivery. The max current output of usb 2 is 500mA and in the drive specs it is written 1A . Recently my drive got a replacement. The part number of the old drive and new drive is the same HDTB105AK3AA. The model number of my new drive is v63700-A. Unfortunately I didn't notice the model number of my old HDD. Also could you please tell me what is the code FAC:C E. My drive is FAC:F E. My new drive is made in philippines. Is there a way to identify the revision of this HDD from its serial number?

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 5 hours [ DST ]

Who is online

Users browsing this forum: No registered users and 1 guest

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group