All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 13 posts ] 
Author Message
 Post subject: Seagate 7200.10 problem :
PostPosted: January 1st, 2019, 10:27 
Offline
User avatar

Joined: December 19th, 2006, 8:49
Posts: 10828
Location: Portugal
Ok, so I'm trying to recover data on this 7200.10 (ST-10) Seagate drive.

Only tool available is MRT as i'm doing this by remote but i did encounter MAJOR problems attempting to do this recovery and I'm stuck.

A donnor drive is available of the exact same model and firmware. PCBs are directly compatible and ROM code is the same.

- Connecting the BAD drive does get MRT to stay "stuck" in BSY. Drive doesn't apear to be loading the ATA overlay. So i placed the known good donor on the MRT to "detect" the firmware details and then when MRT does load the utility (creating a loader from the donor is possible) we swap (NOT HOT SWAP) to the damaged drive without closing the utility so that MRT are "aware" of the correct location of the firmware.

- Powering on the damaged drive does create a "log" like this :

Attachment:
1.jpg
1.jpg [ 100.89 KiB | Viewed 1721 times ]


- The BAD drive reach T> level so we know that adaptives + SA defects + APP code is loaded and then the drive is stuck on BSY with errors.

- Not only something is not correct with ATA overlay but we also get those errors whena ttempting to write to the firmware at drive power up. Those are created by the drive and NOT by MRT. Maybe tehy are S.M.A.R.T. related as it's impossible to re-set S.M.A.R.T. as well.

I do suspect S.M.A.R.T. damage and ATA overlay damage (bad sectors on SA).

It's possible to read ALL SA components and create a loader with DONOR :

Attachment:
2.jpg
2.jpg [ 85.19 KiB | Viewed 1721 times ]


But it's impossible to load that loader on patient !!!

_________________
1Q9xrDTzTddUXeJAFRn37aqh1Yr6buDCdw - (Bitcoin Donations)
paypal.me/Spildit - (PayPal Donations)
The HDD Oracle - Platform for OPEN research on Data Recovery.


Top
 Profile  
 
 Post subject: Re: Seagate 7200.10 problem :
PostPosted: January 1st, 2019, 10:33 
Offline
User avatar

Joined: December 19th, 2006, 8:49
Posts: 10828
Location: Portugal
Here we have more details :

- I can't WRITE the ATA overlay from the good drive back to the damaged drive even by HOT swap. By HOT SWAP the "track" does apear to write but the content written is not correct as it can't be read later.

Attachment:
1.jpg
1.jpg [ 122.75 KiB | Viewed 1719 times ]


- It's possible to drop the drive to safe mode ( F> ) and then load components with R and start app with j . drive does go to T>.

Attachment:
2.jpg
2.jpg [ 79.57 KiB | Viewed 1719 times ]


- It's not possible to read the ATA overlay on the PATIENT. It's possible to READ it from the DONOR but impossible to WRITE it to the patient as well even by hot swap :

Attachment:
3.jpg
3.jpg [ 125.06 KiB | Viewed 1719 times ]


Attachment:
4.jpg
4.jpg [ 114.94 KiB | Viewed 1719 times ]

_________________
1Q9xrDTzTddUXeJAFRn37aqh1Yr6buDCdw - (Bitcoin Donations)
paypal.me/Spildit - (PayPal Donations)
The HDD Oracle - Platform for OPEN research on Data Recovery.


Top
 Profile  
 
 Post subject: Re: Seagate 7200.10 problem :
PostPosted: January 1st, 2019, 10:38 
Offline
User avatar

Joined: December 19th, 2006, 8:49
Posts: 10828
Location: Portugal
- Clearing S.M.A.R.T. does fail as well even if drive is started by HOT SWAP :

Attachment:
1.jpg
1.jpg [ 113.48 KiB | Viewed 1719 times ]


MRT does state that clearing S.M.A.R.T. will make you loose the data ... WTF .... :roll: Ok, clearing S.M.A.R.T. by terminal does fail as well. Guess MRT uses the same N command. Shut down S.M.A.R.T. by terminal does work but doesn't help.

- MRT can't even spin down the drive - function doesn't work - and to hot swap it's necessary to spin down the drive by manual terminal command.

Attachment:
2.jpg
2.jpg [ 152.29 KiB | Viewed 1719 times ]


Attachment:
3.jpg
3.jpg [ 46.94 KiB | Viewed 1719 times ]

_________________
1Q9xrDTzTddUXeJAFRn37aqh1Yr6buDCdw - (Bitcoin Donations)
paypal.me/Spildit - (PayPal Donations)
The HDD Oracle - Platform for OPEN research on Data Recovery.


Top
 Profile  
 
 Post subject: Re: Seagate 7200.10 problem :
PostPosted: January 1st, 2019, 10:45 
Offline
User avatar

Joined: December 19th, 2006, 8:49
Posts: 10828
Location: Portugal
Now my question ....

HOW CAN I RECOVER THE DATA on this drive with MRT ONLY ???

- On PC-3000 I would use a DE task and with active Seagate utility it would be possible to initialize the drive in DE froam a loader. In the current state of the drive i do believe that that it would became ready and it would be possible to image/clone. In PC-3000 i would use exactly the same procedure used for the ST-10 / barracuda classic Pending Bug. APP and ATA should be 100% compatible as PCB swap does work without ROM change.

- On MRT on the other hand I CAN'T FIND any function to do the same (load the drive from loader on DE). :( :( :(

- Loader from the GOOD DRIVE doesn't load the damaged drive as well :( :( :(

- I've read many posts about MRT not handling correctly old ST-10 drives, maybe there is a problem and the ATA overlay can't be loaded because of MRT bug ? At least on families like Venus MRT can't read overlays and have huge problems, maybe it's the same with this 7200.10 ?

- I don't know why a good ATA overlay can't be loaded from loader on the good drive.

- Also there are some threads that talk about MRT not making their loaders as their should and because of that MRT can work with PC-3000 loaders but have trouble with their own loaders ....

Help ?!

Just with MRT is it possible to solve this case and somehow load from the loader and make he drive DRDY / DSC for imaging in DE ?

I can't WRITE to tracks most likely because of bad blocks so i would like to load to RAM the components of the good drive so that the bad drive would boot up in a way that i could clone/image it on DE ...

Any help ?

Maybe someone with experience with MRT can comment on how to make this work ?

Maybe i'm missing something obviouse ?

Thanks !

_________________
1Q9xrDTzTddUXeJAFRn37aqh1Yr6buDCdw - (Bitcoin Donations)
paypal.me/Spildit - (PayPal Donations)
The HDD Oracle - Platform for OPEN research on Data Recovery.


Top
 Profile  
 
 Post subject: Re: Seagate 7200.10 problem :
PostPosted: January 2nd, 2019, 14:49 
Offline
User avatar

Joined: December 19th, 2006, 8:49
Posts: 10828
Location: Portugal
So ... I make a loader with donor (working) :

Attachment:
1.jpg
1.jpg [ 110.68 KiB | Viewed 1625 times ]


Attachment:
2.jpg
2.jpg [ 110.73 KiB | Viewed 1625 times ]


Attachment:
3.jpg
3.jpg [ 107.1 KiB | Viewed 1625 times ]


Now i drop the drive to safe mode (F>) and load APP code and ATA overlay but the drive remains in BSY :

Attachment:
4.jpg
4.jpg [ 118.28 KiB | Viewed 1625 times ]


How do you guys shitch for terminal to ATA on MRT without re-setting the firmware ?

No point in loading ATA + APP if you can gain access by ATA to image/clone ...

Thanks.

_________________
1Q9xrDTzTddUXeJAFRn37aqh1Yr6buDCdw - (Bitcoin Donations)
paypal.me/Spildit - (PayPal Donations)
The HDD Oracle - Platform for OPEN research on Data Recovery.


Top
 Profile  
 
 Post subject: Re: Seagate 7200.10 problem :
PostPosted: January 3rd, 2019, 11:13 
Offline

Joined: October 5th, 2015, 18:53
Posts: 462
Location: Canada
Prepare hot swap donor by copying data related stuff from client drive to donor, start it, change drives, read it.


Top
 Profile  
 
 Post subject: Re: Seagate 7200.10 problem :
PostPosted: January 3rd, 2019, 14:57 
Offline
User avatar

Joined: December 19th, 2006, 8:49
Posts: 10828
Location: Portugal
drHDD wrote:
Prepare hot swap donor by copying data related stuff from client drive to donor, start it, change drives, read it.


Thanks for the tip.

I was doing this over TeamViewer with a "friend" but things are not looking good with that MRT.

I will ask for the "client" to ship the drives to me. Should be fairly easy to do with HRT.

I can easly copy by terminal the tracks containing adaptives, defect lists, etc using HRT but on MRT I'm really stuck. I'm not even sure this thing is loading the ATA properly..... I think it's buggy and it's not working as it should. Also i've read somewhere else that MRT does have big problems with those older ST-10 drives and on some families like Venus, etc can't even properly backup SA ...

I will ask for the drives to be shipped to my location and then i will try your method. Looks very viable.

Thanks once again for the tip.

_________________
1Q9xrDTzTddUXeJAFRn37aqh1Yr6buDCdw - (Bitcoin Donations)
paypal.me/Spildit - (PayPal Donations)
The HDD Oracle - Platform for OPEN research on Data Recovery.


Top
 Profile  
 
 Post subject: Re: Seagate 7200.10 problem :
PostPosted: January 3rd, 2019, 20:08 
Offline

Joined: December 5th, 2011, 5:38
Posts: 1273
Location: Italy
MRT is junk for working on this drives


Top
 Profile  
 
 Post subject: Re: Seagate 7200.10 problem :
PostPosted: January 3rd, 2019, 20:12 
Offline
User avatar

Joined: December 19th, 2006, 8:49
Posts: 10828
Location: Portugal
michael chiklis wrote:
MRT is junk for working on this drives


Agree ...

:twisted: :twisted: :twisted:

_________________
1Q9xrDTzTddUXeJAFRn37aqh1Yr6buDCdw - (Bitcoin Donations)
paypal.me/Spildit - (PayPal Donations)
The HDD Oracle - Platform for OPEN research on Data Recovery.


Top
 Profile  
 
 Post subject: Re: Seagate 7200.10 problem :
PostPosted: January 4th, 2019, 3:02 
Offline

Joined: June 6th, 2011, 4:40
Posts: 23
Location: Ha noi
i'm used pc3000. and same case i don't tick all in save LDR.
CERT code; data ovelay (0). ID , app code
try it

_________________
DATA RECOVERY SERVICE VIETNAM
Cứu dữ liệu ổ cứng| Cứu dữ liệu máy chủ |Phục hồi dữ liệu


Top
 Profile  
 
 Post subject: Re: Seagate 7200.10 problem :
PostPosted: January 4th, 2019, 14:48 
Offline
User avatar

Joined: December 19th, 2006, 8:49
Posts: 10828
Location: Portugal
manhcuongvn wrote:
i'm used pc3000. and same case i don't tick all in save LDR.
CERT code; data ovelay (0). ID , app code
try it


Doesn't work on MRT, I did try only APP and ATA and it doesn't work as well ...

lolol

_________________
1Q9xrDTzTddUXeJAFRn37aqh1Yr6buDCdw - (Bitcoin Donations)
paypal.me/Spildit - (PayPal Donations)
The HDD Oracle - Platform for OPEN research on Data Recovery.


Top
 Profile  
 
 Post subject: Re: Seagate 7200.10 problem :
PostPosted: January 9th, 2019, 5:11 
Offline
User avatar

Joined: November 19th, 2018, 3:14
Posts: 15
Location: india
The case must be very profitable, U5 series not frequently seen on the market these days


Top
 Profile  
 
 Post subject: Re: Seagate 7200.10 problem :
PostPosted: January 9th, 2019, 15:45 
Offline
User avatar

Joined: December 19th, 2006, 8:49
Posts: 10828
Location: Portugal
Alikhan wrote:
The case must be very profitable, U5 series not frequently seen on the market these days


Depends on the country. It's just that F3 will fail WAY MORE so older ST-10 either did fail already many years ago or are still running fine ! lololol

For the record my main machine where i do have my firmware tools and HRT card installed have the OS and main utilities installed on a 2008 ST-10 (Seagate 7200.10). I did run a full scan of the drive on the first day of the year and it doesn't have a single bad sector neither a single slow access sector and the G-List is empty .... Those drives were made to last, unlike F3 ARCH junk ....

_________________
1Q9xrDTzTddUXeJAFRn37aqh1Yr6buDCdw - (Bitcoin Donations)
paypal.me/Spildit - (PayPal Donations)
The HDD Oracle - Platform for OPEN research on Data Recovery.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 13 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 31 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group