All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 20 posts ] 
Author Message
 Post subject: WD5000AVVS - PROBLEM, PLS HELP
PostPosted: April 13th, 2012, 15:34 
Offline

Joined: April 10th, 2012, 13:11
Posts: 15
Location: polish
Hello
I have a problem with the hard drive WD Caviar WD5000AVVS
The problem is that it has established an ATA password.
Please do not remove the subject, I have seen this issue;
Code:
http://forum.hddguru.com/unlocking-ata-password-for-western-digital-t8374-440.html

But I still can not unlock the drive by MHDD.
Every time I try to open the program writes the script, "Incorrect version or batch file"
It's about this script:
Code:
; script name: read md
; reads md 02 on WD drives Marwell
;
reset
waitnbsy

regs = $ 45 $ 0B $ 00 $ 44 $ 57 $ 80 $ a0
waitnbsy

regs = $ d 6 $ 01 $ be $ 4f $ c2 $ a0 $ b0
waitnbsy
checkdrq
sectorsfrom = cs.bin

regs = $ d5 $ 01 $ bf $ 4f $ c2 $ a0 $ b0
waitnbsy
checkdrq
sectorsto = 21.bin

regs = $ d5 $ 01 $ bf $ 4f $ c2 $ a0 $ b0
waitnbsy
checkdrq
sectorsto = 22.bin

end;


What am I doing wrong?
Please help because I really depend on that drive, I have no important data on it.
I`m Polish - translated by google


Top
 Profile  
 
 Post subject: Re: WD5000AVVS - PROBLEM, PLS HELP
PostPosted: April 13th, 2012, 19:23 
Offline
User avatar

Joined: September 8th, 2009, 18:21
Posts: 9286
Location: Australia
If you have no important data, and if the master password is still at its default setting, then you could try the following:
http://cmrr.ucsd.edu/people/Hughes/SecureErase.shtml

_________________
A backup a day keeps DR away.


Top
 Profile  
 
 Post subject: Re: WD5000AVVS - PROBLEM, PLS HELP
PostPosted: April 14th, 2012, 1:58 
Offline

Joined: April 10th, 2012, 13:11
Posts: 15
Location: polish
OK, thanks - we'll see if that works.


Top
 Profile  
 
 Post subject: Re: WD5000AVVS - PROBLEM, PLS HELP
PostPosted: April 14th, 2012, 3:24 
Offline

Joined: April 10th, 2012, 13:11
Posts: 15
Location: polish
How do I use this program? I did.
Iso on the cd, I turned the computer
off the CD, boot the thing itself, then
I had to choose a driver and as a
result could not see the program
window. Before I checked the
windows should look like window.
What should I do?


Top
 Profile  
 
 Post subject: Re: WD5000AVVS - PROBLEM, PLS HELP
PostPosted: April 14th, 2012, 14:11 
Offline

Joined: April 10th, 2012, 13:11
Posts: 15
Location: polish
I managed to run the program, but he unlocked the drive
gave such a password that did not work and did not remove the password disk
also Secure Erase thread because it requires a password.
Where is the saved password?
Disk or in ROM?
And how are things with this script?
I care about this drive.


Top
 Profile  
 
 Post subject: Re: WD5000AVVS - PROBLEM, PLS HELP
PostPosted: April 14th, 2012, 15:05 
Offline
User avatar

Joined: February 27th, 2009, 3:26
Posts: 1691
Location: French Polynesia Tahiti
If you really care about this drive. I think it would be wise to find a person close to you that has the proper tools and know how to unlock this HDD for you. Make suer you take proof of ownership and can prove this is your HDD other wise no respected company will touch this one. There are too many problems to unlock a HDD that does not belong to the right person and nobody in this field will do this one for you with out proof of ownership. This should be simple and not cost you very much to have this one done professionally. Other wise you will need to study HDD, modules, and how all this works with passwords and then buy the tools needed to get it done with. Will be cheapter to take it to a shop in your area and have it done for you.

_________________
Iorana Haraharaini


Top
 Profile  
 
 Post subject: Re: WD5000AVVS - PROBLEM, PLS HELP
PostPosted: April 14th, 2012, 15:48 
Offline

Joined: April 10th, 2012, 13:11
Posts: 15
Location: polish
So it happens that the drive was purchased for allegro.pl - Polish side of the auction. I bought it for 10 PLN or your $ 3-4
The disk was most likely drawn from a set-top box or DVR. Unfortunately, I do not know the person who could, which she could do it. That I am a total geek, these threads - you must want to learn something like that.
But back to the topic - apparently this script to the MHDD really works - so I want to do it.
What is wrong in this script?
I have just noticed the differences in files script - in the example file sample.mba are some strange characters, and in my letters are normal. I figured that the script must be written in some other way - the program?
My script file I created in this way;
First I created a new file in Notepad
Second pasted the script which is located above the subject
Third save as> script.mba
Any ideas?
Here are the files in which I noticed these differences;
Code:
http://www.sendspace.pl/file/44e8c51030fab3b4e09f90f

Code:
http://www.sendspace.pl/file/6b5f6e235e409dc3a7aad26


Top
 Profile  
 
 Post subject: Re: WD5000AVVS - PROBLEM, PLS HELP
PostPosted: April 14th, 2012, 17:12 
Offline
User avatar

Joined: February 27th, 2009, 3:26
Posts: 1691
Location: French Polynesia Tahiti
Did you read this topic? unlocking-ata-password-for-western-digital-t8374.html

_________________
Iorana Haraharaini


Top
 Profile  
 
 Post subject: Re: WD5000AVVS - PROBLEM, PLS HELP
PostPosted: April 15th, 2012, 3:25 
Offline

Joined: April 10th, 2012, 13:11
Posts: 15
Location: polish
So I read this, I wrote about that - but not too well know angileski and the translator is not enough.


Top
 Profile  
 
 Post subject: Re: WD5000AVVS - PROBLEM, PLS HELP
PostPosted: April 15th, 2012, 4:00 
Offline

Joined: April 10th, 2012, 13:11
Posts: 15
Location: polish
wirus wrote:
angileski

*english*

Exactly what the extension should have a script file?
I turned on the editor and created HxD mw.mba and cs.bin
But I noticed that the files in the folder MHDD v4.5 script, the files have the extension - is this what? But how do the file without extension?

----------------------------------
OK, I ran the script finally, now crashes for me "drive reports error"

LOG:
Code:
[PRE]
51 ERR INDX CORR DREQ DRSC WRFT DRDY BUSY        AMNF T0NF ABRT IDNF UNCR BBK 04
  [ Drive parameters - PRESS F2 to DETECT ]   [        Current position       ]
*  CONFIG         Configure a drive. View current config *                     
*  SETCDSPEED     Change current CD speed (IDE only)     *                     
*  UNITSIZE       Change unit size (SCSI)                *                     
*  SCSIFORMAT     Format unit                            *                     
**********************************************************                     
ţ Use command MAN to see detailed help                                         
ţ Press <SHIFT+F3> to select controller                                       
MHDD>.mw.mba                                                                   
MHDD ATA/SCSI TERMINAL v2.1                                                     
Script: MW.MBA                                                                 
ÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄ
LINE 1: RESET                                                                   
LINE 2: WAITNBSY                                                               
LINE 3: REGS = $45 $0B $00 $44 $57 $A0 $80                                     
LINE 4: WAITNBSY                                                               
LINE 5: REGS = $D6 $01 $BE $4F $C2 $A0 $B0                                     
LINE 6: WAITNBSY                                                               
LINE 7: CHECKDRQ                                                               
LINE 8: SECTORSFROM = CS.BIN                                                   
ERROR: drive reports error                                                     
                                                                               
                                                                               
| Help : <F1> and command MAN                                       | 10:06:34
[/PRE]


Top
 Profile  
 
 Post subject: Re: WD5000AVVS - PROBLEM, PLS HELP
PostPosted: April 15th, 2012, 10:50 
Offline

Joined: April 10th, 2012, 13:11
Posts: 15
Location: polish
I figured that I have a bad file cs.bin
Except that I do not know what is in the wrong ...
Does anyone wrzycić Mølby this file to a server?
Or the mail;
mkwirusek82@gmail.com


Top
 Profile  
 
 Post subject: Re: WD5000AVVS - PROBLEM, PLS HELP
PostPosted: April 15th, 2012, 13:12 
Offline

Joined: April 10th, 2012, 13:11
Posts: 15
Location: polish
wirus wrote:
I figured that I have a bad file cs.bin
Except that I do not know what is in the wrong ...
Does anyone wrzycić Mølby this file to a server?
Or the mail;
mkwirusek82@gmail.com



move this file to the server *? - cs.bin


Top
 Profile  
 
 Post subject: Re: WD5000AVVS - PROBLEM, PLS HELP
PostPosted: April 15th, 2012, 18:29 
Offline
User avatar

Joined: September 8th, 2009, 18:21
Posts: 9286
Location: Australia
Use your hex editor to create a binary file of size 512 bytes containing the following hexadecimal data:

Code:
0x000  08 00 01 00 02 00 00 00 00 00 00 00 00 00 00 00
.................................................
0x1f0   00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00


Otherwise you could use Debug in a Windows DOS box, as follows:

D:\>debug
-f 100 2ff 0
-e 100
12EB:0100 00.08 00.00 00.01 00.00 00.02
-rcx
CX 0000
:200
-n cs.bin
-w
Writing 00200 bytes
-q

_________________
A backup a day keeps DR away.


Top
 Profile  
 
 Post subject: Re: WD5000AVVS - PROBLEM, PLS HELP
PostPosted: April 16th, 2012, 12:51 
Offline

Joined: April 10th, 2012, 13:11
Posts: 15
Location: polish
Image




Good?


Top
 Profile  
 
 Post subject: Re: WD5000AVVS - PROBLEM, PLS HELP
PostPosted: April 16th, 2012, 18:23 
Offline
User avatar

Joined: September 8th, 2009, 18:21
Posts: 9286
Location: Australia
http://www.users.on.net/~fzabkar/temp/CS.BIN

_________________
A backup a day keeps DR away.


Top
 Profile  
 
 Post subject: Re: WD5000AVVS - PROBLEM, PLS HELP
PostPosted: April 18th, 2012, 10:16 
Offline

Joined: April 10th, 2012, 13:11
Posts: 15
Location: polish
OMG!
Drive reports error!

Do you have any ideas?


Top
 Profile  
 
 Post subject: Re: WD5000AVVS - PROBLEM, PLS HELP
PostPosted: April 18th, 2012, 18:43 
Offline
User avatar

Joined: September 8th, 2009, 18:21
Posts: 9286
Location: Australia
What does the drive report in response to ID, EID, and Smart Att commands?

_________________
A backup a day keeps DR away.


Top
 Profile  
 
 Post subject: Re: WD5000AVVS - PROBLEM, PLS HELP
PostPosted: April 19th, 2012, 9:51 
Offline

Joined: April 10th, 2012, 13:11
Posts: 15
Location: polish
security; max on

s.m.a.r.t. - realocadet sector count - ALE wcześniej próbowałem remapa - oczywiście się nie dało, a smart pewnie naliczył


Top
 Profile  
 
 Post subject: Re: WD5000AVVS - PROBLEM, PLS HELP
PostPosted: April 19th, 2012, 10:07 
Offline
User avatar

Joined: September 8th, 2009, 18:21
Posts: 9286
Location: Australia
With respect, I think it's time to give up and say goodbye to your $4 investment. :-(

_________________
A backup a day keeps DR away.


Top
 Profile  
 
 Post subject: Re: WD5000AVVS - PROBLEM, PLS HELP
PostPosted: April 19th, 2012, 13:38 
Offline
User avatar

Joined: February 27th, 2009, 3:26
Posts: 1691
Location: French Polynesia Tahiti
:mrgreen:

_________________
Iorana Haraharaini


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 20 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 24 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group