All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 21 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: ST1500LM006 Liquit Damage, Motor not spin
PostPosted: December 1st, 2019, 18:03 
Offline
User avatar

Joined: June 16th, 2018, 12:09
Posts: 307
Location: Turkey
ST1500LM006 Liquit Damage, Motor not spin

Terminal log
Code:
ActiveFW : 00FWVer : 0001DDR detected:32MBDW SIPC status: 00000081SR

and bussy.

Cannot get ROM.
I dont have donor PCB. Couldnt find it in my country .

I need help for repair PCB
Attachment:
ST1500LM006.jpg
ST1500LM006.jpg [ 659.02 KiB | Viewed 718 times ]
Attachment:
ScreenShot_20191202004535.jpeg
ScreenShot_20191202004535.jpeg [ 46.56 KiB | Viewed 718 times ]

_________________
A Recovery Service In Turkey . Veri Kurtarma Türkiye https://www.digitalverikurtarma.com
Donor Drives hdddonormarket.com


Top
 Profile  
 
 Post subject: Re: ST1500LM006 Liquit Damage, Motor not spin
PostPosted: December 1st, 2019, 20:26 
Offline
User avatar

Joined: September 8th, 2009, 18:21
Posts: 12001
Location: Australia
ISTM that, if you are getting output from the terminal, then there can't be much wrong with the PCB, if anything.

Normally you should see the preamp ID in your terminal output. Could it be that the preamp has been damaged?

What voltages do you measure at each of the 3 coils and the diode at the top left corner?

Do you get a different terminal output when the PCB is off the drive?

_________________
A backup a day keeps DR away.


Top
 Profile  
 
 Post subject: Re: ST1500LM006 Liquit Damage, Motor not spin
PostPosted: December 2nd, 2019, 13:25 
Offline
User avatar

Joined: June 16th, 2018, 12:09
Posts: 307
Location: Turkey
fzabkar wrote:
ISTM that, if you are getting output from the terminal, then there can't be much wrong with the PCB, if anything.

Normally you should see the preamp ID in your terminal output. Could it be that the preamp has been damaged?

What voltages do you measure at each of the 3 coils and the diode at the top left corner?

Do you get a different terminal output when the PCB is off the drive?

Same terminal log if power on just pcb. I have posted above that log.

Could you please mark which point voltages would I measure.

Is it possible to check preamp with measure from connection points?

_________________
A Recovery Service In Turkey . Veri Kurtarma Türkiye https://www.digitalverikurtarma.com
Donor Drives hdddonormarket.com


Top
 Profile  
 
 Post subject: Re: ST1500LM006 Liquit Damage, Motor not spin
PostPosted: December 2nd, 2019, 15:07 
Offline
User avatar

Joined: September 8th, 2009, 18:21
Posts: 12001
Location: Australia
http://www.google.com/search?q=coil+inductor+smt&tbs=isz:m,itp:photo&tbm=isch

http://www.google.com/search?q=smt+diode+Schottky&tbs=isz:m,itp:photo&tbm=isch

_________________
A backup a day keeps DR away.


Top
 Profile  
 
 Post subject: Re: ST1500LM006 Liquit Damage, Motor not spin
PostPosted: December 4th, 2019, 11:53 
Offline
User avatar

Joined: June 16th, 2018, 12:09
Posts: 307
Location: Turkey
fzabkar wrote:
ISTM that, if you are getting output from the terminal, then there can't be much wrong with the PCB, if anything.

Normally you should see the preamp ID in your terminal output. Could it be that the preamp has been damaged?

What voltages do you measure at each of the 3 coils and the diode at the top left corner?

Do you get a different terminal output when the PCB is off the drive?
Attachment:
cc,_.jpg
cc,_.jpg [ 531.44 KiB | Viewed 555 times ]

_________________
A Recovery Service In Turkey . Veri Kurtarma Türkiye https://www.digitalverikurtarma.com
Donor Drives hdddonormarket.com


Top
 Profile  
 
 Post subject: Re: ST1500LM006 Liquit Damage, Motor not spin
PostPosted: December 4th, 2019, 12:34 
Offline
User avatar

Joined: March 6th, 2010, 3:46
Posts: 423
Location: Kolding | Denmark
Liquid damage - anything can be damaged
My advise: get a donor pcb in another country, M9T are not hard to find.

_________________
Digitalsupport Data Recovery
https://digitalsupport.dk


Top
 Profile  
 
 Post subject: Re: ST1500LM006 Liquit Damage, Motor not spin
PostPosted: December 4th, 2019, 12:49 
Online

Joined: September 29th, 2005, 4:10
Posts: 266
Location: Moscow
PCB good
Quote:
SIPC status: 00000081SR

Bad ROM.
FIPS or CS ROM
Read ROM on progromator and show here.


Top
 Profile  
 
 Post subject: Re: ST1500LM006 Liquit Damage, Motor not spin
PostPosted: December 4th, 2019, 13:49 
Offline
User avatar

Joined: September 8th, 2009, 18:21
Posts: 12001
Location: Australia
As already stated, those voltages look good.

    Vio = 1.78V
    Vcore = 0.96V

I have written a tool to parse your ROM:

http://www.hddoracle.com/viewtopic.php?f=22&t=1846

_________________
A backup a day keeps DR away.


Top
 Profile  
 
 Post subject: Re: ST1500LM006 Liquit Damage, Motor not spin
PostPosted: December 4th, 2019, 14:09 
Offline
User avatar

Joined: June 16th, 2018, 12:09
Posts: 307
Location: Turkey
Tomset wrote:
PCB good
Quote:
SIPC status: 00000081SR

Bad ROM.
FIPS or CS ROM
Read ROM on progromator and show here.

Tomorrow . I will try to get rom with my unusual methods. If couldn't get ROM dump I would try to read with programmer. I would write last situation in this topic

_________________
A Recovery Service In Turkey . Veri Kurtarma Türkiye https://www.digitalverikurtarma.com
Donor Drives hdddonormarket.com


Top
 Profile  
 
 Post subject: Re: ST1500LM006 Liquit Damage, Motor not spin
PostPosted: December 4th, 2019, 14:10 
Offline
User avatar

Joined: June 16th, 2018, 12:09
Posts: 307
Location: Turkey
fzabkar wrote:
As already stated, those voltages look good.

    Vio = 1.78V
    Vcore = 0.96V

I have written a tool to parse your ROM:

http://www.hddoracle.com/viewtopic.php?f=22&t=1846

Thanks bro

_________________
A Recovery Service In Turkey . Veri Kurtarma Türkiye https://www.digitalverikurtarma.com
Donor Drives hdddonormarket.com


Top
 Profile  
 
 Post subject: Re: ST1500LM006 Liquit Damage, Motor not spin
PostPosted: December 4th, 2019, 15:04 
Offline
User avatar

Joined: February 9th, 2009, 16:13
Posts: 2253
Location: Ontario, Canada
99% of the time, I find that there is absolutely no damage because of the spill and the issue is that the system was bounced around while the drive was still spinning, resulting in the heads getting stuck.

_________________
Luke
RAID Data Recovery


Top
 Profile  
 
 Post subject: Re: ST1500LM006 Liquit Damage, Motor not spin
PostPosted: December 5th, 2019, 6:28 
Offline
User avatar

Joined: June 16th, 2018, 12:09
Posts: 307
Location: Turkey
lcoughey wrote:
99% of the time, I find that there is absolutely no damage because of the spill and the issue is that the system was bounced around while the drive was still spinning, resulting in the heads getting stuck.

Not any moving, any sound. totally silence

_________________
A Recovery Service In Turkey . Veri Kurtarma Türkiye https://www.digitalverikurtarma.com
Donor Drives hdddonormarket.com


Top
 Profile  
 
 Post subject: Re: ST1500LM006 Liquit Damage, Motor not spin
PostPosted: December 5th, 2019, 6:44 
Offline
User avatar

Joined: June 16th, 2018, 12:09
Posts: 307
Location: Turkey
Tomset wrote:
PCB good
Quote:
SIPC status: 00000081SR

Bad ROM.
FIPS or CS ROM
Read ROM on progromator and show here.


Attachments:
st1500LM006.rar [836.15 KiB]
Downloaded 10 times

_________________
A Recovery Service In Turkey . Veri Kurtarma Türkiye https://www.digitalverikurtarma.com
Donor Drives hdddonormarket.com
Top
 Profile  
 
 Post subject: Re: ST1500LM006 Liquit Damage, Motor not spin
PostPosted: December 5th, 2019, 7:29 
Online

Joined: September 29th, 2005, 4:10
Posts: 266
Location: Moscow
ROM too good
****************************************
Из файла................................ : C:\!Profiles\Samsung\st1500LM006\512ROM.bin

Информация о дампе
Размер дампа............................ : 524288 байт
Контрольная сумма микропрограммы........ : Ok
Смещение FIPS........................... : 0x00001000
Размер FIPS............................. : 4096 байт
Контрольная сумма FIPS.................. : Ok
Тип микропрограммы...................... : Main Code
Оригинальное название................... : 2BC72AM.131
Platform Id............................. : 0x1F
Карта головок........................... : 0, 1, 2, 3, 4, 5
****************************************
Тест завершен

Isolate only the Preamp. Leaving the motor contacts.
Does the motor spin?


Top
 Profile  
 
 Post subject: Re: ST1500LM006 Liquit Damage, Motor not spin
PostPosted: December 5th, 2019, 8:05 
Offline
User avatar

Joined: March 6th, 2010, 3:46
Posts: 423
Location: Kolding | Denmark
On the M9T I have seen, isolated head connector or damaged preamp will prevent motor start.
With error: >>>Invalid PA VID
*PA VID=xxxx PN=xxxx Rev=xxxx Invalid Preamp

Have seen faulty PCB stopping @ ActiveFW : 00 FWVer : 0001DDR detected:32MB

I would still look for a tested and working PCB

_________________
Digitalsupport Data Recovery
https://digitalsupport.dk


Top
 Profile  
 
 Post subject: Re: ST1500LM006 Liquit Damage, Motor not spin
PostPosted: December 5th, 2019, 9:11 
Offline
User avatar

Joined: June 16th, 2018, 12:09
Posts: 307
Location: Turkey
I found donor PCB.
Case solved. Drive working properly.
Thanks for advices.

_________________
A Recovery Service In Turkey . Veri Kurtarma Türkiye https://www.digitalverikurtarma.com
Donor Drives hdddonormarket.com


Top
 Profile  
 
 Post subject: Re: ST1500LM006 Liquit Damage, Motor not spin
PostPosted: December 5th, 2019, 15:00 
Offline
User avatar

Joined: September 8th, 2009, 18:21
Posts: 12001
Location: Australia
My tool also finds nothing wrong with your ROM.

Code:
Verifying Samsung SpinPoint ROM:  512ROM.bin

Checksum of Boot Block header = 0x63  - OK
Checksum of Boot Block (Actual/Expected) = 0x7283 / 0x7283  - OK

Searching for FIPS block (expected checksum = 0x0000) ...

Found FIPS text string at 0x001000
Checksum for 0x0400 byte FIPS block = 0xC4E6  - BAD
Checksum for 0x0800 byte FIPS block = 0x7335  - BAD
Checksum for 0x0C00 byte FIPS block = 0x3E92  - BAD
Checksum for 0x1000 byte FIPS block = 0x0000  - OK

Found FIPS text string at 0x00A6EA
Checksum for 0x0400 byte FIPS block = 0xED2C  - BAD
Checksum for 0x0800 byte FIPS block = 0x6E3E  - BAD
Checksum for 0x0C00 byte FIPS block = 0x516C  - BAD
Checksum for 0x1000 byte FIPS block = 0x72A9  - BAD

Found FIPS text string at 0x01C9E0
Checksum for 0x0400 byte FIPS block = 0xDBB2  - BAD
Checksum for 0x0800 byte FIPS block = 0x3763  - BAD
Checksum for 0x0C00 byte FIPS block = 0x07E2  - BAD
Checksum for 0x1000 byte FIPS block = 0x850A  - BAD

Found FIPS text string at 0x02FBFD
Checksum for 0x0400 byte FIPS block = 0xADC5  - BAD
Checksum for 0x0800 byte FIPS block = 0x017E  - BAD
Checksum for 0x0C00 byte FIPS block = 0x7003  - BAD
Checksum for 0x1000 byte FIPS block = 0x834B  - BAD

Possible 0x1000 byte FIPS block at address 0x001000

Searching for FLASHTBL ...

Found FLASHTBL text string at 0x002024
Parsing FLASHTBL at 0x002000 ...

ID Byt1 Byt3    Size   ROM address range   RAMaddrs  Cksm (Exp/Act)
-----------------------------------------------------------------
00  00   FF         0                             0            N/A
01  40   FF         0                         14D00            N/A
02  02   FF       300     2000 - 22FF      FFF02000  00 98   - BAD (Note 2)
03  08   FF      1EC8     2300 - 41C7      FFF02300  31 31   - OK
04  00   FF     14CD8     41D0 - 18EA7            0  33 33   - OK
05  40   FF      2FAC    18EB0 - 1BE5B        14D00  C2 C2   - OK
06  00   FF       B74    1BE64 - 1C9D7        80000  0F 0F   - OK
07  00   FF       37C    1C9E0 - 1CD5B        85C00  E2 E2   - OK
08  00   FF       230    1CD64 - 1CF93        88000  C5 C5   - OK
09  80   FF     4D6F8    1CF9C - 6A693     10018000  13 13   - OK
0A  00   FF      6710    6A69C - 70DAB     900003C0  E3 E3   - OK
0B  08   FF         0                      FFF02300            N/A

Found FLASHTBL text string at 0x04CB1F
Inconsistent ID

Found FLASHTBL text string at 0x0545B3
Inconsistent ID


Searching for SERVOTBL ...

Found SERVOTBL text string at 0x071024
Parsing SERVOTBL at 0x071000 ...

ID Byt1 Byt3    Size   ROM address range   RAMaddrs  Cksm (Exp/Act)
-----------------------------------------------------------------
00  02   FF        C0    71000 - 710BF     FFF71000  00 9C   - BAD (Note 2)
01  00   FF      CA64    710C4 - 7DB27            0  28 28   - OK
02  00   FF       F68    7DB30 - 7EA97        80000  80 80   - OK


Size            - size of module in ROM expressed in bytes
ROM address     - absolute address range of module in ROM
RAMaddrs        - load point of module in RAM
Cksm (Exp/Act)  - Expected Checksum / Actual Checksum


Note 1:  The address range of affected module may conflict with another module,
          in which case this is probably a false negative.

Note 2:  If this module is the FLASHTBL or SERVOTBL, then this is most likely
          a false negative.

Note 3:  This may or may not be a genuinely BAD module. Examine the checksum
          of the first half of the ROM. If 0x0000, then module is probably OK,
          otherwise it may or may not be bad. Also examine the "adjusted"
          checksum, if applicable.

Note 4:  The address range of the module is outside the limits of the ROM.



Calculating ROM checksums ...
Checksum for 0x000000 - 0x03FFFF = 0x02B5
Checksum for 0x040000 - 0x07FFFF = 0x064D
Checksum for entire ROM = 0x0902

Extents reported by FLASHTBL header = 0x000000 - 0x070FFF
Extents reported by SERVOTBL header = 0x071000 - 0x07FFFF

Checksum from 0 to end of SERVOTBL = 0x0902

Checksum (adjusted) from 0 to end of SERVOTBL = 0x0000

_________________
A backup a day keeps DR away.


Top
 Profile  
 
 Post subject: Re: ST1500LM006 Liquit Damage, Motor not spin
PostPosted: December 5th, 2019, 17:22 
Offline
User avatar

Joined: June 16th, 2018, 12:09
Posts: 307
Location: Turkey
@fzabkar special thanks to your kindly helps. I have learned much things from your replies at this forum. Also I realized there could be PCB fault after you asked me some points voltages . I measured more points . I am still learning, but recognized something wrong on PCB. My lucky I could get a borrow donor PCB from a DR company.
I havent try your tool. I would try your tool later. But happy about your tool works

_________________
A Recovery Service In Turkey . Veri Kurtarma Türkiye https://www.digitalverikurtarma.com
Donor Drives hdddonormarket.com


Top
 Profile  
 
 Post subject: Re: ST1500LM006 Liquit Damage, Motor not spin
PostPosted: December 5th, 2019, 17:41 
Offline
User avatar

Joined: September 8th, 2009, 18:21
Posts: 12001
Location: Australia
Here is a similar problem (with no resolution):
https://www.data-medics.com/forum/not-spinning-after-drop-st2000lm003-hn-m201rad-av2-t2018.html

Very strange ...

_________________
A backup a day keeps DR away.


Top
 Profile  
 
 Post subject: Re: ST1500LM006 Liquit Damage, Motor not spin
PostPosted: December 6th, 2019, 3:27 
Offline
User avatar

Joined: June 16th, 2018, 12:09
Posts: 307
Location: Turkey
fzabkar wrote:

Says PCB problem. Donor PCB solved in 2nd page. Same issue

_________________
A Recovery Service In Turkey . Veri Kurtarma Türkiye https://www.digitalverikurtarma.com
Donor Drives hdddonormarket.com


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 21 posts ]  Go to page 1, 2  Next

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: eNDi and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group