All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 31 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: WD Hubble_LT drives smart hot swap problem. Please help!
PostPosted: April 6th, 2016, 7:44 
Offline
User avatar

Joined: November 3rd, 2013, 13:04
Posts: 263
Location: Hungary
Hit here!
I need some help for two cases.
Patient 1 drive is a WD5000LPVX-22V0TT0 / 05.jun.2013 drive. When it came, the drive were identifiable (now it’s not), but all sectors are has CRC error. I inspected modules, and found both copy of module 31, and module 33 were damaged. With Sediv i have read out these modules with „Try Repaire” command (checked CRC is ok). I tried write back these modules, and i have „DISK SERVO WRT FLT OFFTRACK ERROR” error message. I thought the drive has a weak heads. I changed the head stack assembly, but no differece, i still cannot write back modulest to SA, but i can change or edit healthy modules. With original heads i have recovered three other WD5000LPVX drives, so the heads were good!

Patient drive 2 is a WD5000LPVX-75V0TT0 / 05.may.2013 drive. The drive identifiable, when i load overlay module, but both copy of module 31, and module 33 were damaged too, and module 11 is also damaged. I read out these modules with Sediv „Try Repaire” command, and i cant write these modules back. I also have „DISK SERVO WRT FLT OFFTRACK ERROR” error message. Tried change heads regions (change value of region 1 to 0 and write to hdd), nothing helped. Tried change modules offset in module 01 with Sediv directory manager, not helped.

The drives above has a same FW microcode: 1.01A01-5001H

I have some donor drives with same FW microcode and very close manufacturing date. I tried copy patient modulest to donor drive SA, but i cant initialize heads, and i cant access to donor SA with patient PCB (tried short TV9-TV10) i hears silent ssshhhh ssshhh sound from the drive.
When i change patient PCB ROM module 4F to donor PCB ROM 4F, then i can access to donor SA, and i can write patient modules fine. BUT!
When i try a smart hot swap method with donor drive (drive holds copy of patient drive modules) after i wake patient drive, it starts clicking.
My goal is to do a smart hot swap, but i cant access to SA with patient PCB except when i change module F4 in ROM, but this method not help me to access UA sectors because a waking drive starts clicking.

I’m glad if somebody can help, because i have a headache.
Thanks!


Top
 Profile  
 
 Post subject: Re: WD Hubble_LT drives smart hot swap problem. Please help!
PostPosted: April 6th, 2016, 9:31 
Offline

Joined: March 19th, 2015, 15:01
Posts: 1406
Location: isreal
saltwater wrote:
and found both copy of module 31, and module 33 were damaged.

What about:
1. copy 1
2. other critical mod's

both copies have damages in the same location ? (maybe you can get one good copy from both of them, by merging them, then change the location in dir)


Top
 Profile  
 
 Post subject: Re: WD Hubble_LT drives smart hot swap problem. Please help!
PostPosted: April 6th, 2016, 9:47 
Offline
User avatar

Joined: November 3rd, 2013, 13:04
Posts: 263
Location: Hungary
Thanks jermy!
I have good copies thanks for Sediv "Try Repaire" function, but changing location (example to module 04 location) in dir results a same error, i can't write these modules, and changing back dir to original results, i cant write module 04 back. I know it's crazy!
When i start patient drive using short TV9-TV10 TP, then also cant write these modules.


Top
 Profile  
 
 Post subject: Re: WD Hubble_LT drives smart hot swap problem. Please help!
PostPosted: April 6th, 2016, 9:48 
Offline

Joined: October 21st, 2007, 8:48
Posts: 1366
saltwater wrote:
Thanks jermy!
I have good copies thanks for Sediv "Try Repaire" function, but changing location (example to module 04 location) in dir results a same error, i can't write these modules, and changing back dir to original results, i cant write module 04 back. I know it's crazy!
When i start patient drive using short TV9-TV10 TP, then also cant write these modules.

Did you try starting with Ldr?


Top
 Profile  
 
 Post subject: Re: WD Hubble_LT drives smart hot swap problem. Please help!
PostPosted: April 6th, 2016, 9:49 
Offline
User avatar

Joined: December 8th, 2013, 4:48
Posts: 796
Location: Pakistan
saltwater wrote:
Hit here!
When i change patient PCB ROM module 4F to donor PCB ROM 4F, then i can access to donor SA, and i can write patient modules fine. BUT!

here is the problem i think.
what modules you have transferred from patient to donor ?
if you have a drive with same FW version you have to transfer some key modules from patient to donor.

_________________
Data Recovery Pakistan


Top
 Profile  
 
 Post subject: Re: WD Hubble_LT drives smart hot swap problem. Please help!
PostPosted: April 6th, 2016, 10:04 
Offline

Joined: March 19th, 2015, 15:01
Posts: 1406
Location: isreal
saltwater wrote:
but changing location (example to module 04 location)...

Why write to another modules location and not to a free location
saltwater wrote:
i can't write these modules, and changing back dir to original results, i cant write module 04 back.

seams to me heads can read but not write
the fact that you have recovered 3 drives with this HSA before
saltwater wrote:
i have recovered three other WD5000LPVX drives, so the heads were good!

doesn't proof that head can write


Top
 Profile  
 
 Post subject: Re: WD Hubble_LT drives smart hot swap problem. Please help!
PostPosted: April 6th, 2016, 10:31 
Offline
User avatar

Joined: November 3rd, 2013, 13:04
Posts: 263
Location: Hungary
unknown wrote:
saltwater wrote:
Thanks jermy!
I have good copies thanks for Sediv "Try Repaire" function, but changing location (example to module 04 location) in dir results a same error, i can't write these modules, and changing back dir to original results, i cant write module 04 back. I know it's crazy!
When i start patient drive using short TV9-TV10 TP, then also cant write these modules.

Did you try starting with Ldr?


Yes.
Starting drive with shorted TV9-TV10, and loaded overlay (mod 11) still shorted read channels, and init head 0 results i can read and write SA.


Top
 Profile  
 
 Post subject: Re: WD Hubble_LT drives smart hot swap problem. Please help!
PostPosted: April 6th, 2016, 10:34 
Offline
User avatar

Joined: November 3rd, 2013, 13:04
Posts: 263
Location: Hungary
MindMergepk wrote:
saltwater wrote:
Hit here!
When i change patient PCB ROM module 4F to donor PCB ROM 4F, then i can access to donor SA, and i can write patient modules fine. BUT!

here is the problem i think.
what modules you have transferred from patient to donor ?
if you have a drive with same FW version you have to transfer some key modules from patient to donor.


I transferred all modules that i read out from patient. Also i tried transfer 02,31,32,33,34,36 modules, but only with donor PCB i can write modules . With patient PCB i can access SA only when i transfer donor ROM F4 module into patient ROM.


Top
 Profile  
 
 Post subject: Re: WD Hubble_LT drives smart hot swap problem. Please help!
PostPosted: April 6th, 2016, 10:35 
Offline
User avatar

Joined: November 3rd, 2013, 13:04
Posts: 263
Location: Hungary
jermy wrote:
saltwater wrote:
but changing location (example to module 04 location)...

Why write to another modules location and not to a free location
saltwater wrote:
i can't write these modules, and changing back dir to original results, i cant write module 04 back.

seams to me heads can read but not write
the fact that you have recovered 3 drives with this HSA before
saltwater wrote:
i have recovered three other WD5000LPVX drives, so the heads were good!

doesn't proof that head can write


jermy!
I'm come back soon!


Top
 Profile  
 
 Post subject: Re: WD Hubble_LT drives smart hot swap problem. Please help!
PostPosted: April 6th, 2016, 12:13 
Offline
User avatar

Joined: November 3rd, 2013, 13:04
Posts: 263
Location: Hungary
jermy wrote:
saltwater wrote:
but changing location (example to module 04 location)...

Why write to another modules location and not to a free location
saltwater wrote:
i can't write these modules, and changing back dir to original results, i cant write module 04 back.

seams to me heads can read but not write
the fact that you have recovered 3 drives with this HSA before
saltwater wrote:
i have recovered three other WD5000LPVX drives, so the heads were good!

doesn't proof that head can write


So....
I tried write to a free location, but mod 31 sector count is 1445 sectors, the last module on SA is 00B7 module that starts at ABA sector 177401 and it's sector count is 5 sectors. The SA last ABA sector is 177419, so there is no enough space on SA for shift to free location.....i tried, not worked.

The original head can write, because i used it for editing modules on other drives (example mod 02, and relo-list)
With patient 2 drive heads i also can write/edit modules.


Top
 Profile  
 
 Post subject: Re: WD Hubble_LT drives smart hot swap problem. Please help!
PostPosted: April 6th, 2016, 12:37 
Offline
User avatar

Joined: June 8th, 2006, 19:44
Posts: 3021
Location: Atlanta, GA
Some of the Hubble_LTs have limited SA access, akin to self-encryption.

_________________
http://www.datasaversllc.com


Top
 Profile  
 
 Post subject: Re: WD Hubble_LT drives smart hot swap problem. Please help!
PostPosted: April 6th, 2016, 12:55 
Offline

Joined: March 19th, 2015, 15:01
Posts: 1406
Location: isreal
[quote="saltwater"]so there is no enough space on SA for shift to free location...../quote]
There is definitely enough space in between the mod's location


Top
 Profile  
 
 Post subject: Re: WD Hubble_LT drives smart hot swap problem. Please help!
PostPosted: April 6th, 2016, 15:11 
Offline
User avatar

Joined: November 3rd, 2013, 13:04
Posts: 263
Location: Hungary
Ok, thank you, i will try it tomorrow, but why i cant acces to donor SA using patient PCB rom? I only hear ssshh....ssshhh from inside, and can't initialize head(s) except when i use donor ROM F4 module. When i use donor ROM F4 module inside patient PCB ROM, then i can access donor SA with patient PCB. Other WD drives does not works like these Hubble LT drives.
Is F4 ROM module holds some adaptive information? I dont think so..... Using smart hot swap method would be a clean operation.


Top
 Profile  
 
 Post subject: Re: WD Hubble_LT drives smart hot swap problem. Please help!
PostPosted: April 6th, 2016, 15:41 
Offline

Joined: March 19th, 2015, 15:01
Posts: 1406
Location: isreal
ROM F/W ver. of both (patient and donor) are the same ?


Top
 Profile  
 
 Post subject: Re: WD Hubble_LT drives smart hot swap problem. Please help!
PostPosted: April 6th, 2016, 16:50 
Offline
User avatar

Joined: November 3rd, 2013, 13:04
Posts: 263
Location: Hungary
Yes, the drives (patients and donor) has a same FW revision, and microcode: 1.01A01-5001H


Top
 Profile  
 
 Post subject: Re: WD Hubble_LT drives smart hot swap problem. Please help!
PostPosted: April 6th, 2016, 17:12 
Offline

Joined: March 19th, 2015, 15:01
Posts: 1406
Location: isreal
What about the upside, using donors PCB on patient, do you have access to (patients) SA ?


Top
 Profile  
 
 Post subject: Re: WD Hubble_LT drives smart hot swap problem. Please help!
PostPosted: April 6th, 2016, 17:27 
Offline
User avatar

Joined: November 3rd, 2013, 13:04
Posts: 263
Location: Hungary
I tried all possibilities.
donor PCB with patient ROM on patient HDD (nothing changed, write errors on mod 31,33)
patient PCB with donor ROM on donor HDD (works fine)
donor PCB with donor ROM on patient HDD (cant initialize heads)
patient PCB with patient ROM on donor HDD (cant initialize heads)

Have you two Hubble_LT drive with same FW microcode? Try it! Try access to SA with another PCB! My bet, you cant!
I have some healthy WD5000LPVX drives with same microcode, and i cant access X drive PCB to Y drive SA till i change ROM F4 module to original.


Top
 Profile  
 
 Post subject: Re: WD Hubble_LT drives smart hot swap problem. Please help!
PostPosted: April 6th, 2016, 17:58 
Offline
User avatar

Joined: November 3rd, 2013, 13:04
Posts: 263
Location: Hungary
...and yeppp, heads regions are same in ROM 0B and 020 modules......


Top
 Profile  
 
 Post subject: Re: WD Hubble_LT drives smart hot swap problem. Please help!
PostPosted: April 6th, 2016, 18:03 
Offline

Joined: March 19th, 2015, 15:01
Posts: 1406
Location: isreal
saltwater wrote:
I tried all possibilities.

Maybe you have tried all possibilities but not all of them is written here
1 in particular I'm interested to know is
patient PCB with donor ROM on patient HDD ?
saltwater wrote:
patient PCB with donor ROM on donor HDD (works fine)

read and write ?


Top
 Profile  
 
 Post subject: Re: WD Hubble_LT drives smart hot swap problem. Please help!
PostPosted: April 7th, 2016, 5:55 
Offline
User avatar

Joined: November 3rd, 2013, 13:04
Posts: 263
Location: Hungary
Hi!
I found some free space in SA, shifted module 11,31, and 33, i have write the new dir module to disk, so heads can write, then after power reset i loaded overlay, double checked dir module again, and try write these three modules to SA.
Writing mod 11, i have "DISK_SERVO_WRT_FLT_OFFTRACK_ERROR" error.
Writing mod 31, i have "2400 Error code not definied! - 2400 - Error code not definied! - 2401" error.
Writing mod 33, i have "2400 Error code not definied! - 2400 - Error code not definied! - 2401" error.

So how can i do a smart hot swap on these drives?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 31 posts ]  Go to page 1, 2  Next

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: MSN [Bot] and 43 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group