Switch to full style
Data recovery and disk repair questions and discussions related to old-fashioned SATA, SAS, SCSI, IDE, MFM hard drives - any type of storage device that has moving parts
Post a reply

ST3000DM001 not detected in BIOS

January 11th, 2022, 16:28

hello everyone,

I have Seagate ST3000DM001 PN 1CH166-510 FW CC27 hard drive disk.
It spins but is not recognized in BIOS and there is no access to data.
I checked the drive with other but the same pcb board (100717520 rev B) and swap eeprom.
After new pcb installed nothing changed, drive is still not detected.
I have connected it to terminal using usb to RS232 TTL adapter and got some logs.
I don't know if it is important but after "(P) SATA Reset" appears F3 T mode is not accessible.
To get F3 T mode I had to press ctr+z during boot procedure.

after powering up
Boot 0x40M
Spin Up

Spin Up

(P) SATA Reset

heads resistance
F3 7>X

Head 00 Resistance 0102
Head 01 Resistance 013E
Head 02 Resistance 0160
Head 03 Resistance 0147
Head 04 Resistance 0155
Head 05 Resistance 0138

slip defects list
F3 T>V1
Head 0: entries C40 slips 874B
Head 1: entries 295 slips 4670
Head 2: entries 9A slips 28AE
Head 3: entries 21A slips 59AD
Head 4: entries F20 slips 6A76
Head 5: entries C19 slips 8C20
Total Entries 2CC2 Total Slips 246AC

system slip defects list
F3 T>V2

System Slip Defect List
log log log phys phys
LBA span cumm cyl hd sctr zn cyl sctr SFI
0 0 0 0 0 0 0 369EA 0 FFFFFFFF 0
62B42 151BE 151BE 0 1 0 1 35F9C 0 FFFFFFFF 77D00
C5684 151BE 2A37C 0 2 0 2 33524 0 FFFFFFFF EFA00
1281C6 151BE 3F53A 0 3 0 3 31711 0 FFFFFFFF 167700
18AD08 151BE 546F8 0 4 0 4 33C3C 0 FFFFFFFF 1DF400
1ED84A 151BE 698B6 0 5 0 5 2F271 0 FFFFFFFF 257100
25038C 151BE 7EA74 1B0 0 0 6 36B9A 0 FFFFFFFF 2CEE00
2B2ECE 151BE 93C32 1B0 1 0 7 3614C 0 FFFFFFFF 346B00
315A10 151BE A8DF0 1B0 2 0 8 336D4 0 FFFFFFFF 3BE800
378552 151BE BDFAE 1B0 3 0 9 318C1 0 FFFFFFFF 436500
3DB094 151BE D316C 1B0 4 0 A 33DEC 0 FFFFFFFF 4AE200
43DBD6 151BE E832A 1B0 5 0 B 2F421 0 FFFFFFFF 525F00

Head 0: entries 2 slips 151BE
Head 1: entries 2 slips 2A37C
Head 2: entries 2 slips 2A37C
Head 3: entries 2 slips 2A37C
Head 4: entries 2 slips 2A37C
Head 5: entries 2 slips 2A37C
Total Entries C Total Slips E832A

F3 T>V10

P List
phy phy log length
head cyl cyl in symb SFI flags
0 55D25 559C5 DC 8CDE4 80 scr fill
1 55F26 55BC6 23C1 26863 4 G to P
1 55F27 55BC7 23C1 26863 4 G to P
1 55F28 55BC8 23C1 26863 C G to P
1 55F29 55BC9 23C1 26863 4 G to P
1 55F2A 55BCA 23C1 26863 4 G to P
1 56011 55CB1 23C1 25A3D 4 G to P
1 56012 55CB2 23C1 25A3D 4 G to P
1 56013 55CB3 23C1 25A3D C G to P
1 56014 55CB4 23C1 25A3D 4 G to P
1 56015 55CB5 23C1 25A3D 4 G to P
Head 0 Entries: C36
Head 1 Entries: 297
Head 2 Entries: 94
Head 3 Entries: 225
Head 4 Entries: F73
Head 5 Entries: C3D
Total Entries: 2D36

Non-resident G-List
F3 T>V40

Nonresident GList 0 entries returned
Total entries available: 0
PBA Len Flags Phy Cyl Hd PhySctr SFI

Can it be an eeprom chip or firmware issue?

I know that every 7200.14 drive has got an unique firmware and it is not possible to use the eeprom (firmware) from another drive even if it has the same PN and similar SN.

After detection by system I intend to clone the disk sector by sector.

Any suggestions what I can do more to see the drive in BIOS?
I have usb to RS232 TTL adapter only.

Thanks for your help in advance!

Re: ST3000DM001 not detected in BIOS

January 11th, 2022, 19:34

Type in the following commands and tell me what the drive responds with for each one:

F3 T>F"RWRecoveryFlags"

F3 T>F"BGMSFlags"

F3 T>F"PerformanceFlags"

F3 T>F"MediaCacheControl"

(please note it is all case-sensitive)

Just based on the model, it's probably an issue with the media cache or bad sector reallocation. Once you tell me the responses to those, I can tell you the commands to issue to turn off some functions that typically cause these issues.

Re: ST3000DM001 not detected in BIOS

January 12th, 2022, 5:43

Thanks for a quick answer.
I think it can be a cause you mentioned because the at the end drive worked very slow and there was a lot of reallocated sectors visible in SMART.

Here are the results of the commands.
F3 T>F"RWRecoveryFlags"
Byte:009A:       RWRecoveryFlags = 00
Byte:009A:           Bit:0, DISABLE_CORRECTION = 0
Byte:009A:           Bit:1, DISABLE_TRANSFER_ON_ERROR = 0
Byte:009A:           Bit:2, POST_ERROR = 0
Byte:009A:           Bit:3, ENABLE_EARLY_RECOVERY = 0
Byte:009A:           Bit:4, READ_CONTINUOUS = 0
Byte:009A:           Bit:5, TRANSFER_BLOCK = 0
Byte:009A:           Bit:6, READ_SPARING_ENABLED = 0
Byte:009A:           Bit:7, WRITE_SPARING_ENABLED = 0

F3 T>F"BGMSFlags"
Byte:0114:       BGMSFlags = 00
Byte:0114:           Bit:1, BGMS_DISABLE_DATA_REFRESH = 0

F3 T>F"PerformanceFlags"
Byte:0464:       PerformanceFlags = 00 20
Byte:0464:           Bit:0, REDUCED_RAW_TRANSITION_FLUSH = 0
Byte:0464:           Bit:1, REDUCED_AV_RETRIES = 0
Byte:0464:           Bit:2, ID_READ_PARAMETERS_FROM_CAP = 0
Byte:0464:           Bit:4, VJIT_DISABLED = 0
Byte:0464:           Bit:5, ZERO_LATENCY_RD_ENABLED = 0
Byte:0465:           Bit:0, DAR_ENABLED = 0
Byte:0465:           Bit:1, OFFLINE_SPARING_ENABLED = 0
Byte:0465:           Bit:2, JIT3 = 0
Byte:0465:           Bit:3, JIT2 = 0
Byte:0465:           Bit:4, JIT1 = 0
Byte:0465:           Bit:5, JIT0 = 1
Byte:0465:           Bit:6, DISABLE_IDLE_ACTIVITY = 0
Byte:0465:           Bit:7, ENABLE_SELF_SEEK = 0

F3 T>F"MediaCacheControl"
Byte:04B1:       MediaCacheControl = 03
Byte:04B1:           Bit:0, ID_BLOCK_MEDIA_CACHE_SUPPORTED = 1
Byte:04B1:           Bit:1, ID_BLOCK_MEDIA_CACHE_ENABLED = 1

Re: ST3000DM001 not detected in BIOS

January 12th, 2022, 9:25

It's interesting that read/write sparing is already disabled. Did you already mess around with F commands to change something? I've never seen those disabled from the factory.

Anyway, you can also try adding in these changes:

F3 T>F"PerformanceFlags",0060,22

F3 T>F"MediaCacheControl",01,22

Just be aware that using that second one will turn off the media cache and it's possible some marginal amount of recently written data could be lost in there.

As a last resort, you can also try this:

F3 T>/CU10

But, I'd save that as a last resort.

After you make any of these changes, be sure to power the drive off/on for the changes to take effect. Once you get the drive reading, I highly recommend you image using either GNU ddrescue or HDDSuperClone in Linux. You are going to be hitting bad sectors, so you need a program that can handle that. Don't even attempt to image in Windows, it will fail.

Re: ST3000DM001 not detected in BIOS

January 12th, 2022, 12:13

Yes, I have disabled earlier read/write sparing with F command. I found this in one of the topic with similar problem with description that this can help.
I am not an expert in disk repair but I care to do everything very carefully beforehand making sure it won't hurt more the drive.
That's why I'm asking for help from people like you who know what they're doing.

Anyway. The first two commands
F3 T>F"PerformanceFlags",0060,22
F3 T>F"MediaCacheControl",01,22

unfortunately didn't help.
The drive is still not visible in BIOS and starting procedure takes very long time.

With the last command
F3 T>/CU10

do you mean
C>U10 (regenerate MCMT while retaining MC contents)

and this can be just typed directly like you wrote
F3 T>/CU10

and means the same?

Re: ST3000DM001 not detected in BIOS

January 14th, 2022, 4:50

Post a reply