ST2000DM001 Suspected Firmware issue.
Page 1 of 1

Author:  cuddy [ April 16th, 2015, 19:40 ]
Post subject:  ST2000DM001 Suspected Firmware issue.

Hi Guys,

I have a ST2000DM001 that I suspect has some defect list/sector reallocation issues.

Drive Spins up and Becomes ready however when you try and probe it for ID it stays Busy (BSY, DRD, DSC)

The Terminal responds as follows.
Boot 0x40M
Spin Up

Spin Up
(P) SATA Reset

(I press Ctrl-Z and after about 2min It drops me to the F3 Prompt)

I am guessing this is firmware as it doesn't make any ticking noises or anything but rather sounds like a perfectly functioning SD2000DM001 when powered up.
I ran a head Test anyhow.
F3 T>/7

F3 7>X

Head 00 Resistance 0107
Head 01 Resistance 014F
Head 02 Resistance 0132
Head 03 Resistance 014C

F3 7>
Looks all right I guess.

I'm suspecting that the firmware is getting stuck trying to reallocate sectors because of a full defect list or something so I edited the HDD ID using the System file 0x0093 and disabled the sector reallocation stuff and turned on the Show Additional Diagnostics in terminal.

Currently getting this from the terminal.
Boot 0x40M
Spin Up

Spin Up
(P) SATA Reset

MCMainPOR: Start:
User Data Base 0043AE88
Check MCMT Version: Current
MCMainPOR: MCTStateFlags 0000002A MCStateFlags 004000C1
MC061: MainPOR: MC off and MCMT empty
MC057: MainPOR: EXCEPTION: POR Failed General Tms 0000003F
MC062: MainPOR: Feature Disabled...
MSP MainPOR: Feature Disabled by AMPS
6Gb Max Speed lowered to 3Gb for Intel bug
Send Status: COMRESET seen

Still no Drive ID or sector access but it drops me to the terminal much quicker.

Clearly at least one if not all of my heads are functional if I was able to read and modify the system files.

Any suggestions?
I'm a bit reluctant to try the HDD Lock (LED:0000000CC) solution because of the family.


Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group